Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello there, I've got a '05 diesel GT with 109k miles.

Two issues, that I'd like to get help with:

Drivers side windows won't stay up.
Before the issue was that I could only get it up by small increments (repeatedly pressing the button). Then I did the "soft-reset" (10 sec down, then hold...). That was fixed... kind of... now it goes up all the way with one press of the button, but immediately after reaching the top, it goes all the way down. So to keep the window "closed" I have to leave a gap of a few millimeters.
Any fix to that?
Except disconnecting the battery for a short while (worked or other widow issues)?

Second issue:
Clutch pedal is a bit sticky... The clutch works fine, no grinding or anything. Only that when I press it, it seems harder for the ~50% of the pressing distance, after that if becomes more softer...
Sometimes it is soft all the time, for no apparent reason... What could be causing this?
This is my 2nd GT and it has the same clutch pedal behaviour (didn't fix the 1st one and nothing happened). So I'm interested whether there is a fix to make the pedal softer all the time?
"Pedal-pressing-bearings" or something?

Input will be appreciated, thanks.
 

·
Registered
Joined
·
13,685 Posts
Had the the issue with the passenger window where it only goes up in increments. I noticed when it was doing that it would not 'auto' down either. For me I just ran the windows up and down a few times (no reset required) to fix. At one point I don't think the window was dropping when the door was opened either.

All seem ok currently but it has done this at least three times now.

My clutch is the hardest/stiffest clutch in any car I have driven/owned. Just got used to it now.
Mine is a 55 plate GT diesel.
 

·
Registered
Joined
·
205 Posts
For the window fix. Put your window up in small increments all the way to the top do not use the auto function. Once it has reached the top and closed, hold the electric window switch in the 'up' position for 10 secs. Window resets. Mine does exactly the same, I usually have perform the reset every month or so. I believe the long-term fix is a new node. Hope that helps.
 

·
Banned
Joined
·
857 Posts
now it goes up all the way with one press of the button, but immediately after reaching the top, it goes all the way down.
Is that not the ant-trap safety kicking in? The window circuit is supposed to detect when too much current is being drawn by the motor as a result of the window's movement being blocked and put the motor in reverse to prevent injury/damage. Might be that the window is going too far up and the top-rubber is being 'seen' as a blockage?

Might be worth adjusting the height of the glass in the regulator - unfortunately that required taking the door card off but worth a try. If it doesn't solve the problem then leave the door card off anyway as that is half the job of replacing the module.....
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Got the window fixed.
Yes to r11co, it was just like and anti-trap kicking in. So once again I tried the soft-reset with the the window down and holding the button. Did it 3 or 4 times in total and the problem went away after the 4th reset.

And thanks to Alexie for the link. Very helpful. I'll try that fix as well.
 
1 - 6 of 6 Posts
Top