Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Newbee here

I have a problems with a friends Alfa GT JTD 2005 that's causing some headaches, I've searched the forums and cant find the answers I need so starting a new thread.

the issue started with the windows. while in the a garage the windows were dropped and the battery disconnected. When the guys working on the car reconnected the battery the windows wouldn't roll up, so they removed the door panel and "hot wired" the windows to get them up. Now she is left with the following problems.

windows not working: when the window rocker switch is pressed there is a beep but noting else, I cant here any relays clicking, so from that I would say that power is getting to
the switch but not the regulator.

Boot Release not working: when you press the key fob button the indicators flash, but that's all, no servo sound, no relay click, I can open the boot manual with the red pull cord but that's all.

Fuel Filler Flap not opening: Again like the boot the switch will not do anything, the flap can be opened with the red pull cord.

I find it odd that all these things have gone at the same time and my first thought was a fuse, so I had a look in the owners manual and found fuse 60 operates the boot. I eventual found it tucked up behind the dash on the drivers side, only confusion is there are 6 fuse spaces but only 4 are used, and only 4 mentioned in the book but I assume I have the right one, all fuses in that small block are fine.

At this point I have drawn a blank, with out a workshop manual I cant see what relays control what systems, or what else could be causing this.

Any help would be gratefully received.
 

·
Registered
Joined
·
374 Posts
One thing I do know - on my GT when I was having trouble with my windows if I unplugged the driver's window door switch then I could not open the boot (never tried the petrol flap - I don't keep any tools in there, ha ha). So it looks as though many of the electrics to the rear of the car pass through that door switch. Could be a useful place to start. But I wouldn't know where to start in testing or repairing it - replacement is simple enough though - if you can get hold of a spare (they're just so expensive).
 

·
Registered
Joined
·
1,466 Posts
The windows are controlled by the door switch module which is electronic. It directly powers the windows without relays. The module also controls other functions, or they're routed though it at least, boot release, filler flap. I'm guessing "hot wiring" the windows (bad idea) has potentially damaged the electronics in the door switch module causing problems with the other functions.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
The windows are controlled by the door switch module which is electronic. It directly powers the windows without relays. The module also controls other functions, or they're routed though it at least, boot release, filler flap. I'm guessing "hot wiring" the windows (bad idea) has potentially damaged the electronics in the door switch module causing problems with the other functions.
Thanks for the reply's so far guys, much appreciated.:thumbup:

Alexie this was my thinking due to the way the windows need to be calibrated a relay wouldn't give fine enough control. any ideas where I can find the door switch module?
 

·
Vendor
Joined
·
45,421 Posts
If you disconnect the battery of a GT with the windows down you need to do a 'soft reset' of the switch before the windows will operate - hold the switches down for 10 seconds, then up for 10 seconds.

Hard-wiring the window regulators may have back-fed the window switch module and killed it. Quite a lot of vehicle functions are fed through the window switch, one of them is the boot popper so it sounds like the window switch is dead. Do you have a flashing odometer by any chance?
 

·
Registered
Joined
·
3 Posts
Changed mirror left side, removed the door cover, and disconected tjhe switch to wi dows and mirror, reasembeled the hole thing, windows not working, boot opner not working, stereo not working, found one fuse in the regular fusebox on the cabin that was blown, change that and found axillary fusees 60 and so on, all fuses ok. When starting the car blinking km, disabeld the minus, still same problem, Any suggestions to solution on my problem?
 

·
Vendor
Joined
·
45,421 Posts
Changed mirror left side, removed the door cover, and disconected tjhe switch to wi dows and mirror, reasembeled the hole thing, windows not working, boot opner not working, stereo not working, found one fuse in the regular fusebox on the cabin that was blown, change that and found axillary fusees 60 and so on, all fuses ok. When starting the car blinking km, disabeld the minus, still same problem, Any suggestions to solution on my problem?
Needs a proxy alignment. Can be done with a diagnostic tool.
 
1 - 8 of 8 Posts
Top