Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
My GT's passenger door is stuck in the locked position. This causes the central locking to error (lock button on dash illuminated) and obviously no way to get the door open.

I was wondering if anyone here knew what it might be?

I've searched the forum and can't find a similar post.
 
G

·
Guest
Joined
·
0 Posts
Silly but have you tried pushing it shut it may be its not properly latched and that maybe why it wont activate?
Make sure you keep the lock and the hadle hinge regularly lubricated as the handles can be a week point and do snap
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
It looks like it is properly shut but I'll give it a go later tonight. I'd be worried about the solenoid if it had been getting bad over time but it's been fine.

Thanks!
 
G

·
Guest
Joined
·
0 Posts
It is possible the sensor in the lock is faulty but you will need to get it open first.
 
G

·
Guest
Joined
·
0 Posts
only by the lock rods in the door or the normal handle .
It might be worth checking the fuses and relays as listed in the owner book.
Did you have any luck forcing it closed a bit more.Did the light on the dash go off when you pushed the door in?
 
G

·
Guest
Joined
·
0 Posts
To access the rods you need to remove the door card but this is near impossible without damaging the door card you may be able to get some access but not much try this at your own risk. Only other thing you could try is get someone to try the handle whilst disconnecting the battery see if it will open .
 
G

·
Guest
Joined
·
0 Posts
Did you try unlocking it with the key from the outside a bit obvious but had to ask
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
No chance to try anything last night - frantic time at home right now. I'm driving around in my OH's 147 Ti at the moment... so much fun ;)

The GT doesn't have a lock on the passenger door handle, only driver's side.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
Spent time today stripping down the door to see if there was any way to manually activate the lock.

The rod is attached to the handle but no movement at all. I'm not sure what the rod is connected to but it is attached, can't see. It feels physically jammed :-/
 
G

·
Guest
Joined
·
0 Posts
I think there is an electronic sensor on the lock itself try and give it a clean with a bit of WD40 or similar then when it's clean try using a contact cleaning spray could be there is a bit of dirt causing a break in the contact somewhere.
Can you see if the wiring to it is good ?
 

·
Registered
Joined
·
95 Posts
guys, did you get this resolved? I have a 'similar' problem. My problem is that the passenger door would not lock so causing the central locking to open again as soon as I try to lock the doors.
Stragely, my GT has a a lock on the passenger door. Has someone done a dumb thing replacing the handle with one with a key?
The key is not able to lock the door from the passenger side. Something is stopping it from locking either with a key or remote.
I can lock the driver door with the key.
Could this be a fuse or a solenoid, or the body computer?
Sometimes when stationary the computer continously attempts to lock the door but it fails so it keeps trying.
Even when driving along this often happens.
I just bought the car and the lock was fine when I bought it. It started to play up after I washed the car thouroughly. I didn't drown it though. The washing may not have anything to do with it.
My mechanic quickly suspected the body computer but he said he would need to investigate. This made me nervous. It is like giving a blank cheque so I said I would watch it for a while.
I've tried removing the battery but it did not resolve it.
Please help.
 
1 - 13 of 13 Posts
Top