Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Got my GT back from the garage this evening following a clutch, slave and master cylinder replacement and was looking forward to taking it for a spin. Unfortunately once I got to some open road I found that it wouldn't rev past 4000rpm - almost is if the rev limiter had cut in. Same in every gear and neutral.

As the car was driving fine before the clutch was replaced I assume that the garage have mucked something up but does anyone know what it might be?

Will be calling them in the morning and would like to at least sound as though I know what I'm talking about when I demand they put it right
 

·
Registered
Joined
·
15 Posts
Interesting to read that - I had the same problem on a 1.9 JTD 8 valve, never did get to the bottom of it, and in the end I sold it.
 

·
Registered
Joined
·
344 Posts
Got my GT back from the garage this evening following a clutch, slave and master cylinder replacement and was looking forward to taking it for a spin. Unfortunately once I got to some open road I found that it wouldn't rev past 4000rpm - almost is if the rev limiter had cut in. Same in every gear and neutral.

As the car was driving fine before the clutch was replaced I assume that the garage have mucked something up but does anyone know what it might be?

Will be calling them in the morning and would like to at least sound as though I know what I'm talking about when I demand they put it right


Did you ever source the problem??
 

·
Registered
Joined
·
15 Posts
Actually I mentioned the problem a while ago to a local diesel injection specialist, he said it was probably a faulty sensor, which was causing the ECU to limit the engine speed. I wish I'd paid better attention as to which one he said it was likely to be - it was only a casual question as I'd long since sold the car.
 

·
Registered
Joined
·
344 Posts
Actually I mentioned the problem a while ago to a local diesel injection specialist, he said it was probably a faulty sensor, which was causing the ECU to limit the engine speed. I wish I'd paid better attention as to which one he said it was likely to be - it was only a casual question as I'd long since sold the car.
Many thanks will check them
 
1 - 8 of 8 Posts
Top