Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
Hi guys,

I'm wondering if there is anyone out there kind enough to loan me a drivers window switch for a short time to test my window?

Im lost with my fault at the moment and running out of ideas.

My window is stuck in the up position. I have tried both the control units on the passenger door and they are fine.

I lashed a cable across from the passenger connection block, after the control unit, to the driver connection block. Thus going from the passenger switch to the driver motor and low and behold, using the passenger switch it works. But not vice versa. The driver switch will not operate the passenger window.

I do get the tellback beep when pressing the drivers button though. Thinking possibly it has an internal fault. If not, specialist and wiring inspection i guess.

In return I have a soft copy of all the diagrams and descriptions relating to the GT that I could try and reproduce.

Fingers crossed and thanks in advance.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
Problem solved. All the individual parts appeared to work, but just not together.

After all my hunting and scouring of wiring diagrams, it turned out to be the poxy control box pins. Placing pressure on the power connector whilst operating the windows gave me some movement back, so I bent all the pins ever so slightly to allow me a better contact. Hey presto, no hair and 1 year later.
 

·
Registered
Joined
·
5,064 Posts
Well done for keeping up the work! Think I would have given up a long time ago.

Fingers crossed it stays working for you.

I discovered by accident that the windows all drop when I press and hold the unlock on the remote, learning all the time with this car! Keeps you guessing eh??!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Press and hold the lock button, they should, should, should go back up.
Also, you may hear of an illusive hidden fuse box under the dash. Well it's there alright. Two 20A and one 10A fuses in a little plastic cage. Behind the normal fuse box. The 2x20A are for the window circuits according to the circuit diagrams.
 

·
Registered
Joined
·
374 Posts
Hi Gav, is the fix still working?

I've had my GT for a month or two now and in the last couple of weeks my drivers window has gone crazy. It started off by refusing to go back up. After much swearing and head scratching I discovered that opening and closing the door made it climb up in 2 inch increments until it got back to the top. Then it was OK for a couple of days.

Then one day I couldn't open it (could hear the little beep behind the dash so the switch must be doing something). I cleared that with the "ECU" reset trick (battery off and complicated key routine) and it worked fine (well I could do the window reset trick and then it was fine).But once again only for a couple of days.

I read that old batteries have random strange effects on the electronics and spotting that mine was the original factory fitted one I replaced it with a nice new one with a higher CCA. Disappointingly no change.

My next thoughts were about the physical restrictions on the glass itself, cleaning and lubricating thechannels and the glass and the rubber it faces on, it runs a lot smoother and freer now but still it will only run to the lowest position if I keep my finger on the button (I can't get it to do the press and release thing) and going back up is only acheived in 2" bursts mostly with the button but sometimes by opening and closinfg the door.

I've had a couple of "false dawns" thinking it was fixed but it only ever lasted a day or two. Has your making tthe connecting pins contact better given you a longer term result?
 
1 - 5 of 5 Posts
Top