Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Evening all,

It appears my door microswitch is having a paddy! When the door was open and I was grabbing my coat off the back seat, the window kept slightly jumping and the door light was going on and off - so I assume that's the case?

Anyone had this and know where to locate the bugger?
 

·
Registered
Joined
·
2,757 Posts
I doubt its the microswitch..

this is normally the window WCU. its located in the lower right side of the door as you look at it from inside the car , you can remove and clean it /dry it out by undoing just the bottom of the door card, some screws if I remember correctly.

disconnect the battery before disconnecting any wiring or WCU and door switches...especially the window switch as its a can node and can cause all sorts of issue's if you are unlucky.

had exactly the same issue on both doors, in both cases replacement WCU's was the fix, they can be had for about £40 on ebay ut try the remove and clean first.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
I see! I'll give it a go tomorrow when there's a bit of light, I assume theyve gotten wet?
 

·
Registered
Joined
·
2,757 Posts
yup, that's what happened with mine on the OS ,the NS blew whilst working on the OS, hence my suggestion that you dis-connect the batt before doing anything. 99 times out of a 100 it would be fine but you may get a surge and it can blow PCB's very easily.


good luck:thumbup:
 
1 - 4 of 4 Posts
Top