Alfa Romeo Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
Ok so I read over shiney_car's thread a hundred times and finally decided that the CTSAR001.2 was the easiest option for me to install my Sony MEX-BT3100U Bluetooth head unit. Seemed to be a nice plug and play option even if the volume would be a little louder.

So....it arrived today. I followed the slim instructions that came with it and I got nothing. HU won't even turn on. All I got was a faint whimper that it was at least alive and then nothing.

Can anyone see the obvious mistake I have made? I am 100% sure it's something I've done wrong :lol:

I tried swapping the ignition and permanent even though the instructions said not to...and still nothing :(

Any help much appreciated
 

Attachments

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,716 Posts
The CTSAR003 would have been a better choice unfortunately. Any chance of changing? It would be plug and play.

However, you can make the CTSAR001 work, no issues. :)

There is no ignition (switched 0V to +12V) wire in the Alfa GT's plug. You will need to connect a switched wire to the interface and Sony. When you turn your ignition key on, it will activate the interface and the Sony, turning both on.

A good source for an ignition-type wire is the cigarette lighter powerwire. Access the lighter's plug underneath, and connect to the middle of 3 wires. Connect this so that it feeds to the red wire going to the interface and Sony.

Also ensure the Alfa's main powerwire in the plug - labelled Ub, in position A7 - is directed to the yellow wire in the interface, and to the yellow wire going to the Sony. In the photo, it currently looks like it originates from the A4 position.

Quite do-able. :)
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #4 ·
You are a legend mate...i will give this a bash tonight! i did read this in your guide but i think i had an issue with information overload :)
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #5 ·
A good source for an ignition-type wire is the cigarette lighter powerwire. Access the lighter's plug underneath, and connect to the middle of 3 wires. Connect this so that it feeds to the red wire going to the interface and Sony.
Ok so....before i go hacking at wires I thought i would make sure i understood your points....and its quickly becoming obvious that i dont :lol: So i decided to do a childlike picture lol. You say connect the cig lighter to the red wire going to the interface and the sony, so i am assuming you mean the one conneting between the Connects2 box (is this the interface?) and the ISO plugs. Youll love this pic :lol:

https://www.flickr.com/photos/[email protected]/14567808215/

Also ensure the Alfa's main powerwire in the plug - labelled Ub, in position A7 - is directed to the yellow wire in the interface, and to the yellow wire going to the Sony. In the photo, it currently looks like it originates from the A4 position.
Yes you are correct, possition A4 has 2 yellow wires, one going to the interface and one going to the ISO adaptor for the Sony. How would I go about repositioning this to the A7 position?

Thanks in advance for your help, apologies for my hurrendous lack of understanding here lol Never had to think about this in the past...simply whipped the old HU out and connected up the plug and play adapter and bobs your uncle lol
 

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,716 Posts
lol picture works. :D

However, is there a red wire coming from the plugs (right of picture) too? Or is there only a red wire from the CTSAR001 to the Sony? From other internet photos of this interface, I think I see a red wire from the main plugs (right of picture) going to the far plug (left of picture), with a branch back-tracking to the interface. Correct? If so, they are all connected in continuity with each other, which means you photo is spot-on correct, and you can connect the cigarette lighter wire like you've shown. HOWEVER, also disconnect it from the main plug (right of picture) because it is originating from position A7, where your yellow wires need to be; insulate any bare terminals (eg: heat shrink or quality electrical tape).

Regarding the yellow wires, ideally you unlatch the terminal from the plug (right of picture), and reposition the yellow wires to A7, to match up with the Alfa Ub power supply. You will need a small jeweller style flat blade screwdriver to push aside the tiny locking tab. Hence, remove the red wire from A7, and reposition the yellow wires from A4 into A7.

If you can't unclip them with a screwdriver, then you can of course cut the wires, and rejoin (eg: solder/heatshrink, or crimp-on bullet terminals).

:)
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #8 ·
lol picture works. :D

However, is there a red wire coming from the plugs (right of picture) too? Or is there only a red wire from the CTSAR001 to the Sony? From other internet photos of this interface, I think I see a red wire from the main plugs (right of picture) going to the far plug (left of picture), with a branch back-tracking to the interface. Correct? If so, they are all connected in continuity with each other, which means you photo is spot-on correct, and you can connect the cigarette lighter wire like you've shown. HOWEVER, also disconnect it from the main plug (right of picture) because it is originating from position A7, where your yellow wires need to be; insulate any bare terminals (eg: heat shrink or quality electrical tape).
Correct mate, there is a red wire coming from the main plug on the right up to the far plug on the left. So if they are connected in series then am i right to think it doesnt matter where I connect it as long as i connect to one of those red wires? So if i was to disconnect it from position A7...i could just put a bullet connector on that lose wire to the cig light and then i have no bare terminals to worry about?

Regarding the yellow wires, ideally you unlatch the terminal from the plug (right of picture), and reposition the yellow wires to A7, to match up with the Alfa Ub power supply. You will need a small jeweller style flat blade screwdriver to push aside the tiny locking tab. Hence, remove the red wire from A7, and reposition the yellow wires from A4 into A7.

If you can't unclip them with a screwdriver, then you can of course cut the wires, and rejoin (eg: solder/heatshrink, or crimp-on bullet terminals).

:)
ah ok...i didnt know you could actually disconnect the wires from the plug! Looks like i have some fun to do tonight. Cant wait to have my music back :thumbs:

thanks again for your help mate
 

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,716 Posts
i could just put a bullet connector on that lose wire to the cig light and then i have no bare terminals to worry about?
Yes, that would be a good way to do it.

:)
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #10 ·
One step forward....the HU now turns on :)

But I have no sound lol. I did as you said above...which has given me power when ignition is on...but for some reason there is no sound at all :(
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #11 · (Edited)
Ok I think I can see why this doesn't work now. There are no connections coming from the yellow mini iso at all, therefore C6 to trigger the bose amp is not connections to the blue/white wire on the Sony harness. The Sony rem out is connected to A5.

So I either bought the incorrect harness from nexxia or they have sent me the incorrect harness. Need to investigate what I actually ordered, although it seems I will have lost my money anyhow as I've chopped at the wires now :(
 

Attachments

·
Registered
Joined
·
94 Posts
Discussion Starter · #12 ·
Managed to do it in the end!

I didn't really want to cut the wires going into the alfa mini ISO block but thought as long as I put bullet connectors in place I can always put the original HU back in.

So that's what I did, cut the C6 wire, put a bullet connector on and connected it to the don't remote out wire and bobs your uncle!

Thanks to shiney_cars help on here and the sticker thread I figured it out and am now a happy boy with my music streaming back in my life :)

Thanks again Shiney
 

Attachments

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,716 Posts
No probs, and well done.

:)
 
1 - 13 of 13 Posts
Top