Alfa Romeo Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
it reaches 100c
new radiator
new thermostat (not the thermostat housing)
new water pump
it happens only in hot days.
the radiator was replaced from the 2.5 to the gta one today but didn't help.

any thoughts?
thanks
 

·
Registered
Joined
·
4,932 Posts
Does the cooling fan kick in and bring it back down to 90?

Do you use the aircon and do you hear the cooling fans on while the engine is running?
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
yes the cooling fan brings it back to 90 when standing idle.
I heats up with air con and without.
 

·
Vendor
Joined
·
46,352 Posts
When you say "reaches 100 degrees", is this on the dashboard gauge or on the ECU's live data output to a diagnostics device?
 

·
Registered
Joined
·
4,126 Posts
That sounds about normal. Mine goes just over 90 in traffic or pressing on then drops back down to just below 90 when the fans kick in.
 

·
Registered
Joined
·
913 Posts
156 GTA does not have full canbus (it has two coolant temp sensors), whereas GT 3.2 and 147 GTA do (also 166 3.2) (they all have only one coolant temp sensor). To my knowledge it should always be showing 90, doesn't matter what is the outside temperature, or at least mine in 166 does.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #9
its only in the last few months started rising over 90, I have the car for 6 years never went above 90. could it be something with the fans even though they work ? I don't know what's left to check or replace.
 

·
Registered
Joined
·
913 Posts
yes the cooling fan brings it back to 90 when standing idle.
I heats up with air con and without.

This makes no-sense. When aircon turns itself on, then cooling fan turns itself on as well, so at least with the aircon being turned on, it should never go over 90. So check this again.

Is first stage of cooling fan working? Or is it only 2nd stage that works?

1st stage is weaker, 2nd stage of course stronger.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #11
I know it makes no sense ,
just got back from a drive with the air con on, the car heats up I can hear and i've checked the fans, they both work on the second speed. it returs to 90 at some point, doesn't matter If standing idle or while driving. maybe the fans are weak ?
 

·
Registered
Joined
·
913 Posts
The only thing left to replace is coolant temp sensor, it's around 20€ or something, and see what happens.

What I do not understand is, if the fan is on while aircon is on and the engine still reaches 100 (driving or idle), what cools it back down to 90 then?
 

·
Registered
Joined
·
1,390 Posts
Was a metal impeller water pump used when it was replaced?

Mine was replaced with a plastic impeller pump a couple of years ago when the cambelt was done (I did not realise this at the time) and two or three months later the car started running warm when accelerating hard, or at high speed etc. This was eventually traced to the water pump and a cracked impeller that was spinning on the shaft.

Since a metal pump has been fitted the temp had only gone over 90 in the south of France last summer when it was 40 degrees and I was pulling up steep hills (I've only got a 2.5 rad which probably didn't help).
 

·
Registered
Joined
·
37 Posts
Discussion Starter #14
The only thing left to replace is coolant temp sensor, it's around 20€ or something, and see what happens.

What I do not understand is, if the fan is on while aircon is on and the engine still reaches 100 (driving or idle), what cools it back down to 90 then?
that's also what I don't understand.


and its a metal pump and only happens In hot days 40 degrees.
 

·
Registered
Joined
·
1,390 Posts
That's similar to what I found in the south of France last summer then. The only time the car showed over 90 degrees was when the outside temp was showing as around 40 degrees. No problem on slightly cooler days.
 

·
Registered
Joined
·
4,126 Posts
The only thing left to replace is coolant temp sensor, it's around 20€ or something, and see what happens.

What I do not understand is, if the fan is on while aircon is on and the engine still reaches 100 (driving or idle), what cools it back down to 90 then?
Isn't it the first stage fan that is on with the aircon, then the secondary high speed fan cuts in to bring the temp down?
 

·
Registered
Joined
·
913 Posts
Yes that is how it suppose to work (to my knowledge at least :)). But on my 166, 2nd stage kicks in well before I notice any rise of temperature on temp gauge.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #18
i'm almost certain that once the ac is on the fans are on the second speed.
i'll plug in the ecu tomorrow to check .
maybe the first speed doesn't work?
 
1 - 19 of 19 Posts
Top