Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hi I had the MCSF light come on and the faults I got are as follows:

P0156 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 2) - Present
P1161 - Lambda 2 heater below catalyst - Intermittent
P0159 - O2 Sensor Circuit Slow Response (Bank 2 Sensor 2) - Intermittent
P1172 - Mixture 1 strength (multiplicative) - Present
P1175 - Mixture 2 strength (multiplicative) - Present

Im guessing the mixture strengths relate to the lambda faults? is there any common issues I should beware of before I just go out and replace the lambdas.

Driving wise I guess it does lose power now and again but not all the time and also the idle is sometimes erratic, other than that it drives fine and mpg hasn't really changed that much either.

Any help much appreciated.
 

·
Registered
Joined
·
2,271 Posts
Sometimes a week battery can give spurious codes. Check it is +12 with ignition off and +14 with it on or there abouts.
 

·
Registered
Joined
·
780 Posts
Sometimes a week battery can give spurious codes. Check it is +12 with ignition off and +14 with it on or there abouts.
12.6v or more is what you want with the ignition off, not just 12. Anything below 12.6v indicates the battery is reaching the end of its life cycle and if it is lower than 12.5v then its definitely time to replace it.

Though I do think OPs faults seem more likely to be lambda related than battery. But it never hurts to check the battery first.
 

·
Registered
Joined
·
2,657 Posts
It looks like most of the codes relate to one particular lambda, and it would be unlikely that the heater element and the sensor itself would fail at the same time. I would start by checking the wiring to bank 2 sensor 2 to make sure all was well. Wiring can be a problem for the lambdas on the JTS, more typically the sensors in the manifold (bank 1 sensor 1, bank 2 sensor 1).
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
Many thanks for the replies. With regards to the Lambda am I right in thinking bank 2 sensor 2 is post cat and right hand side (looking from front).
Hoping its not a big deal and a new sensor/wiring repair will do the trick ok.
 

·
Registered
Joined
·
2,271 Posts
Many thanks for the replies. With regards to the Lambda am I right in thinking bank 2 sensor 2 is post cat and right hand side (looking from front).
Hoping its not a big deal and a new sensor/wiring repair will do the trick ok.
Check battery! We are not making it up. Weak battery can give all sorts of codes.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #8
I'll check the voltage on the battery tomorrow and give feedback once done. Thanks again
 

·
Registered
Joined
·
20 Posts
Discussion Starter #10
Yes I've cleared the codes and the same ones come back on, not instantly after a bit of driving
 
1 - 10 of 10 Posts
Top