Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,923 Posts
Discussion Starter #1
I'm hoping someone can give me a suggestion to what's causing an annoying issue with my GTV !

Basically on sweeping left hand bends I get a rubbing / grinding sound from offside rear wheel.

I thought initially it was the worn suspension but I've had that all changed. Along with new rear Spring pans and doglegs all powerflexed !

I don't have this on right hand bends only on left hand bends. Also at high or low speeds the rubbing noise / vibration is the same.

I'd describe it like the tyre rubbing on the arch to detail the noise it makes and it seems to come from the rear offside wheel area !

Any suggestions gladly received.
 

·
Registered
Joined
·
1,729 Posts
Wheel rubbing on springpan maybe. I had this on mine when it had after market wheels on which were the wrong offset. Take the wheel off, the rubbing marks should be easy to spot.
 

·
Registered
Joined
·
270 Posts
I've had something similar.
It was caused by a small metal guard on the bottom of the back of the front brake disc. When turning this can rub on the disc.
If the noise on yours is coming from the rear I don't know if there is something similar on the rear brake discs but worth checking as it is simple and cheap to sort out.
Chris
 

·
Registered
Joined
·
2,575 Posts
I've just replaced my rear bumpstops as I was getting the right-rear tyre rubbing on the top of the wheelarch in spirited cornering. The bumpstops were OK the day I bought the car and both broken a week later. I suggest checking them just to be sure :)

-Alex
 

·
Registered
Joined
·
334 Posts
Another item to check is the rear suspension upper front track control arm.
I had this seize in the sub-frame and took ages to find the noise. May not be the issue but worth a check.
 

·
Registered
Joined
·
1,923 Posts
Discussion Starter #9
Thanks all, bearing might be the issue but there is no noise or vibration on straight sections.

I've had new rear bump stops fitted
New Springpans with powerflex bushes
I've checked the brake disk covers and they aren't rubbing
So that rules that those I think

Would the bearing only cause an issue when under extra load or cornering ?

Thanks again
 
1 - 10 of 10 Posts
Top