Alfa Romeo Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi I have problem with my 156jtd glow plug control unit. The car runs ok at the moment but will need a new before winter comes in. Does anyone know where I can find one and how much they are?
thanks
 

·
Registered
Joined
·
208 Posts
Too late, it's already winter!

Get the part no from eper and google it, at least that's wher I would start, dealer would be last resort for me.
 

·
Registered
Joined
·
9,912 Posts
P0380 error, had glow plugs done and lad done diag when I was gettin me remap done. I've looked all over net. Mates a mechanic and can get me one for £77 like. But was hoping to get part number.
so i take you had error ,then had glow plugs replaced and the error is still there after a reset:confused:
 

·
Registered
Joined
·
52 Posts

·
Registered
Joined
·
66 Posts
part number

Just had new relay fitted(had spark plugs fitted before above post) problem solved. It's the black box bolted to bulkhead(near power stearing bottle) part number 51771823. Was £108.04 in the end but got it under warranty(3 days before it expired!):thumbs:
 

·
Registered
Joined
·
24 Posts
I managed to get the part from a local Fiat dealer for £89 inc VAT. I took the old unit apart (read as butchered) to see what the problem was 5 of the joints had gone dry, once cleaned and re soldered the unit worked fine :) Anyone else having this problem should try and get the unit apart first and re soldering the dry joints before having to spend their money. Also, remember to disconnect the battery before removing the control unit, getting a socket on the + connection without touching earth is quite tricky:eek:
 

·
Registered
Joined
·
550 Posts
Well ive got a flashing glow plugs light also. And it keeps flashing for quite a long time (30s or more, im not sure). Ive also got a P0380 relay fault so suspecting the control unit since the flashing is intermittent + the plugs were checked a couple of months ago (although that was about a month or so before all this began so its probably possible one or more of them died in the mean time). Is that plausible or are the plugs still the most likely suspect?

Also if i were to measure plugs resistances the procedure would be to first unplug the plugs connector off the control unit, then turn the key to MAR and then measure each connection's resistance inside the connector (with the other measuring point being the earth)?
 

·
Registered
Joined
·
518 Posts
Frankly it appears to me that the glow plugs and relay are only there for decoration. Has anybody ever actually had problems starting in even the worst UK winter?
 
1 - 20 of 23 Posts
Top