Alfa Romeo Forum banner

Giulietta USB port problem

4396 Views 4 Replies 3 Participants Last post by  MrMickS
I've just picked up a used Giulietta and after taking a USB stick in and out a few times I can no longer push the stick in far enough for it to register. It goes about halfway in and no further. As a consequence I have no media available.

It seems that there is something stopping the USB stick going all the way into the port. Has anyone else had this problem? If so how did you fix it?
1 - 5 of 5 Posts
I had a problem with my old ipod not properly securing so I bought a USB extension cord and I now lie the ipod down in the glove box. It works a treat (I think it was the weight of the ipod that was causing it to become dislodged).
Thanks but I am using an extension cord. The problem is that the USB plug won't go all the way into the socket. Its as if there's something blocking the plug from going all the way in.
have you tried another usb stick to determine if it's that as opposed to the car??
Yeah. I've tried a couple. In the end I checked with the local dealer and they think that the previous owner must have been a little rough with it. The upshot is that they are going to replace the port. Thankfully as its an approved used car they've extended the warranty and its covered :)
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.