Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi folks, I have a 2011 G (owner from new) and still in love with it today as much as I was when I first drove it off the forecourt! My question relates to the blue&me system - and basically how [email protected] it is! I love everything about the car, except the B&Me system - utter rubbish (n)

I have recently changed my phone (well, been given a work phone) which is an iPhone 7, running iOS 13.3.1 (i'm no fan of apple but a free phone contract is too good to turn down right...!). Anyway, so since I have changed phones and re-connected, the car connects to the phone bluetooth fine but whenever I accept a call it just drops out and returns to the phone... and then comes back to the car speakers... and then drops out... and then... so on! Its abit of a pain. Does anyone know of any compatibility issues? I have "unpaired" and "repaired" the device but its still not working as it should - my previous Samsung had no problems at all :)

Also, whilst on the subject... is there anyway to play music from your phone through the speakers? The phone option is great (when it works!), but given the rubbish that is played on today's radio stations i'd much prefer that i could listen to something much more tasteful on my commute.... Not sure if there is some sort of device that you can buy to make the USB socket in the glove box more than just a power socket...?!

Thanks in advance guys (y)
 

·
Registered
Joined
·
28 Posts
Hi folks, I have a 2011 G (owner from new) and still in love with it today as much as I was when I first drove it off the forecourt! My question relates to the blue&me system - and basically how [email protected] it is! I love everything about the car, except the B&Me system - utter rubbish (n)

I have recently changed my phone (well, been given a work phone) which is an iPhone 7, running iOS 13.3.1 (i'm no fan of apple but a free phone contract is too good to turn down right...!). Anyway, so since I have changed phones and re-connected, the car connects to the phone bluetooth fine but whenever I accept a call it just drops out and returns to the phone... and then comes back to the car speakers... and then drops out... and then... so on! Its abit of a pain. Does anyone know of any compatibility issues? I have "unpaired" and "repaired" the device but its still not working as it should - my previous Samsung had no problems at all :)

Also, whilst on the subject... is there anyway to play music from your phone through the speakers? The phone option is great (when it works!), but given the rubbish that is played on today's radio stations i'd much prefer that i could listen to something much more tasteful on my commute.... Not sure if there is some sort of device that you can buy to make the USB socket in the glove box more than just a power socket...?!

Thanks in advance guys (y)
I also have the exact same problem the blue and me unit/module part number is 50521292 don’t know if this can be updated or not or even changed to a newer module I haven’t had any luck so far the wife’s Samsung works great tho Typical lol
 

·
Registered
Joined
·
332 Posts
Have you tried updating the blue&me software?

my iPhone works very well for music.

I use a Brodit clip with a magnet on it, and a hidden lighting cable from the glovebox which pops out above the heater controls.
When I get in the car, I slap the iPhone on and connect the cable and I am good to go.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thank you for responding...

@armoore So firstly, when you say it does work with yours? which iphone are you using, and are you simply plugging the lightening charger cable into the USB and it works? What setting do you have on your radio? I have done some research on here and I have an earlier model which only has the USB point and no AUX in the glovebox (there seems to be a talking point around this!).

@pezzodicento In terms of Blue&me software... I have never updated this and have no idea how to - do you have any guidance? or a link? I suspect it still has the same software from when the car was built in 2011 so this could be the answer considering the advancements in phone technology.

I also note on a couple of other posts that there is a cable that has a bluetooth link to it which you can buy and plug into the back of the CD changer, although all links to these cables seem to be expired and I can't find any other links on Amazon or Ebay.

Thank you (y)
 

·
Registered
Joined
·
5,458 Posts
I've used iPhone 4, 4s and 6s. All have worked via Media Player, I just scroll through steering wheel control until it starts playing.
 

·
Registered
Joined
·
28 Posts
Have you tried updating the blue&me software?

my iPhone works very well for music.

I use a Brodit clip with a magnet on it, and a hidden lighting cable from the glovebox which pops out above the heater controls.
When I get in the car, I slap the iPhone on and connect the cable and I am good to go.
Hi I haven’t tried a up date I wasn’t sure if you could with this 50521292 module
 

·
Registered
Joined
·
28 Posts
Hi I haven’t tried a up date I wasn’t sure if you could with this 50521292 module
Regarding music yip mine is ok it’s the message reader that’s not picking up any messages as in txt messages none atall doesn’t tell me if there is any I can call and connect to the USB port for music I was told at Arnold Clark Linwood Alfa dealer it’s can’t be updated to be honest I think he just didn’t cate to much as he wasn’t getting a sale
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Update!
Today I have managed to successfully update the software to v10 of blue and me.. its abit of a pain but easy enough in the end. I have made a couple of calls now and it seems to be ok, an improvement on the phone stability and the calls don't seem to be dropping out now - time will tell!

No success on the music streaming front though.... doesn't work with a lightening cable attached, and have tried with various formats... Amazon music, Spotify, Itunes etc... (Amazon being the preference!).
 

·
Registered
Joined
·
290 Posts
Update!
Today I have managed to successfully update the software to v10 of blue and me.. its abit of a pain but easy enough in the end. I have made a couple of calls now and it seems to be ok, an improvement on the phone stability and the calls don't seem to be dropping out now - time will tell!

No success on the music streaming front though.... doesn't work with a lightening cable attached, and have tried with various formats... Amazon music, Spotify, Itunes etc... (Amazon being the preference!).
You will need the blue&me adaptor to stream music, my iPhone 7 streams perfectly with one
 

·
Registered
Joined
·
290 Posts
No worries @Payney123. Mine is Gen 1 so will only update to 5.6. I don’t use mine for calls anymore as it was so unstable. It’s great for streaming though.
 

·
Registered
Joined
·
332 Posts
Update!
Today I have managed to successfully update the software to v10 of blue and me.. its abit of a pain but easy enough in the end. I have made a couple of calls now and it seems to be ok, an improvement on the phone stability and the calls don't seem to be dropping out now - time will tell!

No success on the music streaming front though.... doesn't work with a lightening cable attached, and have tried with various formats... Amazon music, Spotify, Itunes etc... (Amazon being the preference!).
Well done getting the Bluetooth sorted. It is a bit abut of an old school approach.

I have a 2011 G with both USB and aux sockets. Not sure if this means that I have a different B&M module, meaning that lightning cable works ok for my iPhone music. (Including all apps, YouTube, WhatsApp etc

Additionally, I vaguely remember reading in the forums that in iOS, having one song in the Apple Music app makes a difference. Give it a try.

I mainly use Apple Music so can’t verify this. However there is one annoyance I have with the system: sometimes, when I connect my phone, the first alphabetical song starts playing automatically (instead of what I was listening to earlier). Maybe this is related to this whole thing.

I personally think early Bluetooth streaming sounds crap, hence never tried a Bluetooth adapter.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #14
Further update
The phone issue is now solved. The v10 update has made the phone calling very stable which is great news.

I also purchased a Blue and Me adaptor (£60!!) to try and get the music streaming issue sorted, and surprise... with no luck! I plugged the adaptor into the glovebox USB, and then my phone into the adaptor... and nothing. No connection, no charging sign, nothing. I then tried my phone direct into the glovebox usb port and it charges fine.

@pezzodicento and @jdajames ... sorry! Did you have to do anything to install the B&me adaptor? The instructions just simply say plug it in and it'll work. I'm going to call the company I bought it from tomorrow to see if they can help at all. I wonder if the b&me adaptor is compatible with v10 software? i'm hopeful that I can get it working with Amazon Music!
 
1 - 14 of 14 Posts
Top