Alfa Romeo Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hi,

I was wondering if someone could help or may have had similar problems. I recently bought a new battery for my Giulietta after the original gave up (2010 Car). My car has start stop so I bought an AGM battery this one in fact Lion 096 AGM Car Battery With 3 Year Guarentee

My car works fine it has good voltage (12v with the engine off, then 14ish with the engine on). but less than a few minutes driving I get the icon on the dash saying that start stop has been disabled. this is different to it saying 'start stop is unavailable' which sometimes happens and is normal.

Any one else experienced anything like this?

Thanks
 

·
Registered
Joined
·
1,794 Posts
You might think this unlikely but I'd suggest you've fitted the wrong battery.

The preferred battery seems to be the Varta E39 AGM.

I had a new AGM battery fitted under warranty but S/S only ever worked infrequently.

From reading threads on this Forum I decided to take the plunge and bought a Varta E39 (last June) and S/S has worked perfectly ever since!
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
only the black with yellow top in the Lion battery range is AGM. did they deliver the one you ordered?

Yeah it's that one in the photo. It's def agm. I'll check it tomorrow though just to make sure. I thought any 096 AGM battery would work? I called euro car parts and they say that if they enter the reg of my car into their website that battery doesn't come up as being compatible. But that's exactly what I did when I bought it. They were having none of it... It's used so I can't return it and it's not faulty so they can't swap it. Despite the fact that when I ordered it, it did show as suitable for my car.

So now I don't know whether it's right or wrong! Great eh!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,794 Posts
Must admit I did feel rather silly buying another new battery when the existing one was still starting the car OK. Wasn't a total loss though as sold the original one year old "AGM" for £50 on ebay.

Looking back it's one of the best thing I've done to the car as hate stuff that doesn't work properly.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Must admit I did feel rather silly buying another new battery when the existing one was still starting the car OK. Wasn't a total loss though as sold the original one year old "AGM" for £50 on ebay.



Looking back it's one of the best thing I've done to the car as hate stuff that doesn't work properly.

I recon that's what I'll end up doing too. I'm the same I hate when the light comes on, on the dash! :(

Can you do me a favour and post a link to the one you bought? It might save someone else this expensive quest for electricity lol


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,342 Posts

·
Registered
Joined
·
38,284 Posts
Yeah it's that one in the photo. It's def agm. I'll check it tomorrow though just to make sure. I thought any 096 AGM battery would work? I called euro car parts and they say that if they enter the reg of my car into their website that battery doesn't come up as being compatible. But that's exactly what I did when I bought it. They were having none of it... It's used so I can't return it and it's not faulty so they can't swap it. Despite the fact that when I ordered it, it did show as suitable for my car.

So now I don't know whether it's right or wrong! Great eh!


Sent from my iPhone using Tapatalk
It was a mistake on their website which said it was suitable for your car when it wasn't.

I would insist that they allow you to change it otherwise you will be taking matters further.

Go onto their site beforehand and do a screenshot of the incorrect battery listed against your reg number.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #10
It was a mistake on their website which said it was suitable for your car when it wasn't.



I would insist that they allow you to change it otherwise you will be taking matters further.



Go onto their site beforehand and do a screenshot of the incorrect battery listed against your reg number.

I tried... They are right it doesn't come up now when I put my reg in. But it did in November when I ordered. I don't have a screenshot of the website when I ordered so I'm pretty screwed.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
32 Posts
Discussion Starter #12
Before you buy a new battery check the start stop fuse under the bonnet. I had the same thing and tried endless things to solve and it turned out to be a fuse.



This was my thread



http://www.alfaowner.com/Forum/alfa-giulietta/654481-oh-no-another-stop-start-thread.html



Hope it works



David

That's an excellent point! Thank you. It was jump started so I am going to check this fuse. I'll report back. Many thanks for taking the time to reply


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
38,284 Posts
If the fuse had gone wouldn't a message come up saying the stop start had a fault?

Normally it just comes up stop/start unavailable when it cannot work due to conditions or battery charge etc.
 

·
Registered
Joined
·
178 Posts
Hi, thats what I thought. The message is different and occurs only once 5 mins after start up. The message is orange not red. Once I had identified the blown fuse stop start worked perfectly although within the usual air con, battery status, etc etc parameters.
it worked for me anyway
 

·
Registered
Joined
·
32 Posts
Discussion Starter #15
I have the same symptoms as you but I just checked that fuse and it's intact :( I guess I'll be buying another battery then


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,794 Posts
That's the one I have fitted and it works great (9 months on now) unlike the previous AGM which didn't
 

·
Registered
Joined
·
32 Posts
Discussion Starter #18
Ok in gonna get one now. Hopefully will fix the light on the dash and it's not a trip to the stealers I'll report back in case it helps anyone. Grazie


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
32 Posts
Discussion Starter #19
Battery fitted, same problem. I'm so gutted and 200 odd quid in now.... Can these be code read with obd2 like fiats?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,794 Posts
What's this light on the dash you have ?

Always best to check error codes (if you have any) with tools like MultiECUScan + ELM327 adapter with the 3 coloured leads. Plenty on eBay.
 
1 - 20 of 28 Posts
Top