Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi, new to this forum.

I have an Alfa 147 Twin Spark Lusso, 2003. I was driving on the motorway today, and all of a sudden, everytime i powered on in 5th, it popped out of gear. the other gears were fine, jsut happened in fifth.

Later, it got stuck 3rd for a minute or so, then seemed to be ok again.

Obviously i have a problem, but does anyone know what sort of damage i might be looking at? may i possibly have to replace the whole gearbox? and if so, any idea what this is going to cost?

any help would be great...
 

·
Registered
Joined
·
30,202 Posts
There can be a problem with swarf building up in the end of the gearbox.
You can get to it just by removing the gearbox endplate.
You don't need to remove the gearbox from the car.

Having said that, you could also have a problem with the linkage itself.

The swarf issue usually results in being unable to select 4th though.
 

·
Registered
Joined
·
85 Posts
I was driving down the M4 in my Rover 200 a few years back, and had the same problem with it popping out of 5th. I figured I'd ignore it until finally it popped out and didn't go back in.

Turned out that the gearbox oil was low, and 5th gear basically melted on me. That unsuprisingly meant a new gearbox. I don't want to be alarming; I'm far from the most knowledgable bloke on these forums, but please learn from my mistake and don't leave it.

Here's hoping it's nothing major!
 
1 - 4 of 4 Posts
Top