Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
363 Posts
Discussion Starter #1
Hi,

On my Brera (S) 2.2, I've found that switching from 1st to 2nd is becoming increasingly difficult to engage. It's not that it slips out, it simply needs a fair amount of ooomph to shift the gear stick into position. Not such an issue for other gears although it's never been a particularly smooth or easy gearbox to play with.

I recently had the M32 gearbox refurbed and the guy that did it commented on the gear change afterwards (I'd already noticed it so it's not caused by the refurb) and he said he thinks the selector cables might need looking at.

Is this a known issue? Is it cheap (and/or an easy DIY job) to inspect and adjust these cables? Anybody out there had a similar issue and can give me any tips?

Thanks in advance.

Regards,
James
 

·
Registered
Joined
·
78 Posts
Hi,

On my Brera (S) 2.2, I've found that switching from 1st to 2nd is becoming increasingly difficult to engage. It's not that it slips out, it simply needs a fair amount of ooomph to shift the gear stick into position. Not such an issue for other gears although it's never been a particularly smooth or easy gearbox to play with.

I recently had the M32 gearbox refurbed and the guy that did it commented on the gear change afterwards (I'd already noticed it so it's not caused by the refurb) and he said he thinks the selector cables might need looking at.

Is this a known issue? Is it cheap (and/or an easy DIY job) to inspect and adjust these cables? Anybody out there had a similar issue and can give me any tips?

Thanks in advance.

Regards,
James
You can prise them off the selector fork pretty easy and they just push (tap with mallet) back on, see what the gear stick is like without the cables attached.

They're held together by a bracket attached to another attached to the top of the gearbox, I expect you can lengthen or shorten them by screwing the bolts up/down against the bracket they sit in.

I've just had my box off to change DMF and flywheel, its 1.59 2.4 and F40 box so maybe different = I didn't need to adjust either, selector fork in and cables back on - every gear super smooth.

Hope it helps
 

Attachments

·
Registered
Joined
·
2,612 Posts
Remove,clean and grease the pivot pin for the vertical movement selector on box,it is held by a retaining clip engine side then slides out towards battery. Mine was sticky which caused the vertical movement selector to not spring back to the neutral position by itself.

THis was on m32 box.
Also once you done that check cable adjustement,the lever in car locks with the plastic spring loaded clip on nearside and selector on box has hole to put 3 or 4 mm (can’t remeber exact size) in and lock that in position then adjust cables to suit.

One cable has ratchet mechanism other cable has threaded end,on the threaded joint mine was worn so purchased some Peugeot gearbox links and used the end off that.
 
1 - 4 of 4 Posts
Top