Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
368 Posts
Discussion Starter #1
So what do you think is going on here? This gaiter/boot seems shredded to pieces! Any idea what could have caused this? Also, could this be the reason I've been getting creaks/thuds when steering close to full lock at low speeds...?

In which case, what other parts am I going to need to order in?
 

·
Registered
Joined
·
3,217 Posts
So what do you think is going on here? This gaiter/boot seems shredded to pieces! Any idea what could have caused this? Also, could this be the reason I've been getting creaks/thuds when steering close to full lock at low speeds...?

In which case, what other parts am I going to need to order in?
Any signs of corrosion or play in the rack end?
If all ok I would say it’s just a failed gaitor,they have a fair range of movement so if perished it will muller the gaitor.

As for the noise worth a check of the filter inside PAS resavoir,also the upper arms can cause noises when worn
 

·
Registered
Joined
·
2,888 Posts
Depending on how long it’s been like that, as stated above ensure the shafts aren’t corroded/pitted as it could be a new rack?
If just surface rust then clean the shafts and lightly grease before fitting a new gaiter.
If the rack is groaning and creaking then it ‘could’ be a shot rack, especially if you have play in it or leaks from the seals?
 

·
Registered
Joined
·
270 Posts
It looks like the gaitor just started to split due to age, wear and tear... Rubber perishes of its own accord. Combine that with the lateral movement of the rack and it opens further and further until it disintegrates as per your photos, that's completely normal and to be expected. Rubber that is loose rests on the top of the outer shaft then gets jammed against the rack body just tearing it to bits..
It may also be worth your while trying to source some new outer oil seal o rings for the rack body as they will bound to be scored and eventually start leaking fluid. You may think they are ok for now and once the new boot is fitted all is good. However a few month later that new boot may be full of power steering fluid, dragging it downwards with the weight of the fluid and end up catching again tearing it to shreds so back to square one!
 

·
Registered
Joined
·
368 Posts
Discussion Starter #5
Thanks all. It really just looks like surface rust so I'll give them a clean-up and hope that solves the noisy slow steering issue. No other symptoms of a rack issue and the fluid level is good with no discolouring or contaminants.
 

·
Registered
Joined
·
2,569 Posts
That looks like outside damage. Unlikely to be this bad from just something striking it so I would think you have an animal eating it!
 

·
Registered
Joined
·
2,888 Posts
Actually, after zooming in on the first pic - I think the boot has come off the inner retainer & sprung forward so that the knuckle has been wearing it away as you have been driving, this has been like that for a while???
I also thought...that looks nothing like mine!?? Just read you have the 2.2....Lol
 
1 - 7 of 7 Posts
Top