Alfa Romeo Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
329 Posts
Discussion Starter · #1 ·
Came back from abroad recently got into the car turned the ignition & the fuel warning light was on even though the guage indicated half a tank. Not wanting to run out I put some in & drove home.
Now the light comes on at half a tank but guage works normally (I think)
Is there anyone out there with experiance of this problem & is it fixable
 

·
Registered
Joined
·
3,806 Posts
Yeah, I`ve had this problem and its a 'bent or broken bit' on the sender unit in the tank. It easy enough to see how it all works if you take the unit out the top of the tank but fixing is a bit harder - you either need a new unit (you can seperate the pump and tubing) or fix what you have with some careful bending and bodging. Trouble is, if you fix it you don`t know how acurrate it is without refitting it a few times with just a gallon of petrol in the tank to get the level right.
If you are careful I guess a second hand spare would do but be careful you dont damage this one when removing it from the donor car as they are a tight fit into the tank and easily bent upon removal if you are too rough.
 
G

·
Hi Guys,
The Petrol light on my V6 comes on at 1/4 tank, which I guess probably due to a similar reason as Chris describes. The gauge however is fairly accurate, so I just ignore the light now.

Mark. :)
 

·
Registered
Joined
·
447 Posts
Mark, I hope you disabled the light also, I hate that lamp burning on my retina, but I also had that prob, got it replaced when my fuel pump had gone
 
1 - 4 of 4 Posts
Top