Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
Hi guys,
I was wondering if anybody's tried alternative fuel pump like Walbro etc for their 147, 156 or GT.. If yes, kindly suggest some.

I need something of higher spec than our original to support my modification on my 1.6L 147...

or Any body tried installing a Fuel regulator on our returnless fuel lines.. Pls advise..
 

·
Registered
Joined
·
67 Posts
Discussion Starter #4
Why do u say so? So if i need to have uprated fuel pumps to support my fuel starvation issue, what do you suggest i do...
 

·
Registered
Joined
·
2,657 Posts
Have you fitted a turbo? I take it it's running lean at high revs/load, even with the injectors at max duty cycle? Have you fitted bigger injectors also?

It would take major mods before a bigger fuel pump was required - don't think too many people here would have gone that far. You could ask in the tuning lounge.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #7
Modded.. Custom exhaust fr extractors to backbox, port & polish, balance engine, Custom airbox, lighten flywheel, MSD ignition stacker, reprofile 2L cams...
 

·
Registered
Joined
·
9,912 Posts
im sure standard pump can handle increased flow rates you need with your mods unless its tired,your maf sensor should be able to handle the increased flow rates from your mods
are the cams dialled in properly,is ignition timing correct,maf sensor faulty that would give same fuel starvation problem ...have you done a plug chop?, to see if she is running lean top end,how is the throttle in relationship of power ie,when flooring it is it losing power,but what happens if you back off on accelorator a bit does power increase
can you be more precise with your assumptions ie how you come you know its fuel starvation
by the way a badly ported/polished head will give same symptons even reprofiled and poorly timed in cams
 

·
Registered
Joined
·
67 Posts
Discussion Starter #10
Hey bro..
Thanks for the info...


1) When flooring at my higest rev its starts to be flat .. Eg at 215km/h at 6500rpm...
2) When i ease on the pedals , it comes back
3) I blew an engine after all that testing
4) Plugs were destroyed.. the ceramic broke and when into the head
5) Found out the others plugs were mix of black and brown...

I hope by changing my fuel pump to a walbrow would help with the pressure to push and feed the engine with more fuel..

1) I have the MSD iginition which help gives better and smmother firing
2) Running an open pod for more Air
3) So i'm guess i need more fuel to compensate
4) ECu is still stock
 

·
Registered
Joined
·
2,657 Posts
The way to get the correct amount of fuel required by your modified engine is to program the ecu to suit. The ecu determines how much fuel the engine gets by controlling how long the injectors stay open. A bigger fuel pump won't change that. Seems your mods have taken the engine beyond what the standard ecu can cope with.

This is assuming all else is ok as davealfa11 mentions above. But the symptoms you describe are classic lean engine.
 

·
Registered
Joined
·
9,912 Posts
at 6500 isnt the fuel injection killed by ecu at that point?
i would get it on dyno and remap or take it to someone who knows his stuff, good luck
 

·
Registered
Joined
·
67 Posts
Discussion Starter #14
Mine gets cut off at abt 7100rpm... which is mind boggling... so yeah.. i'll do that and check it on the dyno...
 
1 - 14 of 14 Posts
Top