Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
Hi,

I have a rough idling problem with my 159 1.9 jtdm. Today I checked its fuel pressure regulator with multiecuscan. And I recorded its video and upload it (its link below). as you see in the video, while idling, pressure regulator's graphic is like zigzag. I guess it must be near and also smooth with desired fuel pressure. at high rmps desired pressure and fuel pressure regulators pressures are nearly same and there is no zigzag at fuel pressure regulator. after engine warm up (about 90 C), my idling starts to be smooth (you can see after the third minute of the video)...

I also checked the socket of rail pressure regulator. I measured 3.5V at left one, and 12.3V at right one in the pic. but eLearn is telling that, it must be greater then 11V but mine ise 3.5V.... I am not sure that if I am measuring the true pin... :/ ? while this measurement engine's temp was about 90C. maybe measurement must be done with cold engine:/ its photos are at attechment.

What is your ideas about my rough idling? is it about fuel pressure regulator or any other think... ?

Thanks...

Not: there is no any fault code.


 

Attachments

·
Registered
Joined
·
1,768 Posts
i would say so, regulator and fuel pressure looks close enough and zig zag trace is normal to some extent as fuel rail is constantly being pressured and de-pressured as injectors fire.
i would look to injector correction values 1234 and see what you have there.
post results if you want you are looking for values of +/- 0.6 or better values of around 1-2.5 may be noticable in lumpy running and not conclusive of shot injectors on its own , it tells the story of all things that may give engine imbalance of things like compression , air restrictions , burning oil , engine physical problems , may all show up in injector balance.
log from cold start and allow to warm up and try a few revs from idle to 2000rpm steady and then a few fast blips.
if readings show maybe issue first check would be engine off try disconnect and reconnect injector plugs a few times to clean up contacts, see if improves , also historical issues with injector plug has been seen in jtd and cdti requiring new plugs being available to solder into loom(related to cylinder 3 mostly from what ive seen)
https://www.alfaowner.com/Forum/attachment.php?attachmentid=886505&stc=1&d=1558876987
an example of what to expect probably 2 cyl + and 2 cyl - to balance out = sum zero = smoothest running.
see what you have
 

Attachments

·
Registered
Joined
·
118 Posts
Discussion Starter #3
i would say so, regulator and fuel pressure looks close enough and zig zag trace is normal to some extent as fuel rail is constantly being pressured and de-pressured as injectors fire.
i would look to injector correction values 1234 and see what you have there.
post results if you want you are looking for values of +/- 0.6 or better values of around 1-2.5 may be noticable in lumpy running and not conclusive of shot injectors on its own , it tells the story of all things that may give engine imbalance of things like compression , air restrictions , burning oil , engine physical problems , may all show up in injector balance.
log from cold start and allow to warm up and try a few revs from idle to 2000rpm steady and then a few fast blips.
if readings show maybe issue first check would be engine off try disconnect and reconnect injector plugs a few times to clean up contacts, see if improves , also historical issues with injector plug has been seen in jtd and cdti requiring new plugs being available to solder into loom(related to cylinder 3 mostly from what ive seen)
https://www.alfaowner.com/Forum/attachment.php?attachmentid=886505&stc=1&d=1558876987
an example of what to expect probably 2 cyl + and 2 cyl - to balance out = sum zero = smoothest running.
see what you have
thanks for answer.

My injector plugs replaced with new ones about 1 year ago. Also I rechecked my injectors. they
disassemble the injectors, control with the device. and they told me that there is no any problem with my injectors. I also send their correction value diagram with pic. 3th injector is between 1.5-2.5 while idling. I will add a better picture. do you have any idea about my injectors ? I will also do compression test in a few days. as you told, I could have a problem with my engine :/
 

Attachments

1 - 3 of 3 Posts
Top