Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
550 Posts
Discussion Starter #1
I really don´t believe it. I´m going for the third new fuel level sender now, again !!! :rant:

Is there so comon such a waste of pounds in this stuff ? :(
 

·
Registered
Joined
·
13,236 Posts
Are these genuine AR parts? Is a garage doing the job (i.e. are they actually fitting the new part they're charging you for?). It's strange that you been constantly knobbled by such a rare (?) problem.

Ralf S.
 
W

·
Guest
Joined
·
0 Posts
Especially when you consider Jorge has the lowest mileage 155 here........whats the fuel quality like where you are? Perhaps crap fuel is causing premature failure but I have no idea why.......electrical problem???

wrinx
 

·
Registered
Joined
·
550 Posts
Discussion Starter #4
Yes, they are genuine parts, and like you say wrinx fuel quality is not the best here. :(
I always use the liqui moly octane plus because of that problem.
Government had announced a new 98 octane fuel at the new year but..............................................we are still waiting it. :confused:
It´s the internal resistance that get mud so the panel instrument gets nut and begin to go from empty to full without stop. :eek:
 

·
Registered
Joined
·
13,236 Posts
I'm not convinced. My old dad was always having trouble with his fuel sender until I discovered he was fixing it himself. In the end he got fed up with it and fitted a whole new arm/sender unit and never had any more trouble. I wonder if your garage is just soldering up (etc.) the old one ...

Ralf S.
 
1 - 5 of 5 Posts
Top