Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
402 Posts
Discussion Starter #1
Hi,

i have searched the threads as regards the fuel injector light on my 1997 Spider, but! the fuel injector problem appear to be different to mine!?

If im tootle-ing about town say in a higher gear than i need to be on low down the rev range in a high gear my fuel injector light comes on and remains on until i plant the throttle of my bella and then when the car gets a bit frisky the light goes out and remains out unless i begin tootle-ing again. The car is not running high temp, nor is it burning oil and performance i feel is fine!?

Any ideas?

Karma
 

·
Registered
Joined
·
16,710 Posts
Well, I'd still check the water just in case it is low - that can cause the light to come on.

Mine also used to come on due to an electric fault which made the fan come on too, I think it was caused by a bad earth...
 

·
Registered
Joined
·
402 Posts
Discussion Starter #3
Hi Gary,

sory for delay in getting back but! have literally been snowed under last week or two. Funny you should say the water as i didi have to top it up lately in expansion tank as level was very low. then since then nothing really until yesterday when the light did come on again!?

I will check later when i get home from work (The water level) and if its the same thing then i guess i better be looking out for leaks!?

It only seems to come on when im in too high a gear to keep the car on its toes! ie in 4th when it would be better in third, then when i sink the throttle it disappears again until the next time i lift of the gas!!!

Lord these cars are worse than woman!

Karma.:lol:
 

·
Registered
Joined
·
16,710 Posts
Well, if it is a leak part of the hose goes close to the engine, and its this part that tends to fail. It took me a long time to find my leak as it only happened when the car was hot and the water/hose expanded.

Good luck :)
 

·
Registered
Joined
·
402 Posts
Discussion Starter #5
After bringing my car to Euofix and John maxwell , gary you have been proved correct! I had the car in for its 2nd cam-belt change and whilst in i asked john to have a look into the injector light problem and once i returned he had replaced the water pump whilst at the cam-belt. Guess what!??? No more injector light!:cool:
 

·
Registered
Joined
·
16,710 Posts
:thumbs: I'm glad you got it sorted :)
 
1 - 6 of 6 Posts
Top