Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter #1
I've been trying to solve an annoying vibration which only happens when taking a right hand bend and under load. Its more noticable going around a roundabout and if you accelerate the vibration is very noticable and gearstick wobbles and if you let your foot off the accelerator it stops vibrating. Its just gone thru its mot and it needed a cv joint on the left side and wishbone on drivers side. I got the mechanic to look at it and he checked all joints and mounts and could'nt find anything wrong. I rang another mechanic ( alfa specialist) and explained the problem and he said that it could be one of the wishbones. He said there are 2 wishbones lower and upper at the front. I've checked on the web etc and i can't find any reference to there being 2 wishbones on each side at the front. Maybe he meant the rear but i don't think that the problem is coming front the rear as the vibration seems to be coming from the front.

rgds
 

·
Registered
Joined
·
3,189 Posts
I'm pretty sure GTVs don't have top wishbones, he's mixing the GTV up with a 156/147/GT which do. Maybe one of your engines mounts is broken or worn.
 

·
Registered
Joined
·
7,731 Posts
I've been trying to solve an annoying vibration which only happens when taking a right hand bend and under load. Its more noticable going around a roundabout and if you accelerate the vibration is very noticable and gearstick wobbles and if you let your foot off the accelerator it stops vibrating. Its just gone thru its mot and it needed a cv joint on the left side and wishbone on drivers side. I got the mechanic to look at it and he checked all joints and mounts and could'nt find anything wrong. I rang another mechanic ( alfa specialist) and explained the problem and he said that it could be one of the wishbones. He said there are 2 wishbones lower and upper at the front. I've checked on the web etc and i can't find any reference to there being 2 wishbones on each side at the front. Maybe he meant the rear but i don't think that the problem is coming front the rear as the vibration seems to be coming from the front.

rgds
If he's said that then he's not a specialist.
 

·
Registered
Joined
·
38,877 Posts
Vibration could be the top engine mount "Dog Bone".

It can look ok at a glance even if it is knackered.
 

·
Registered
Joined
·
229 Posts
Discussion Starter #6
Thanks for the replys. I don't think he misunderstood me as he asked the year of the car which is 1999 so it definately not a gt. It could be the dogbone engine mount although it seems ok as when i rev the engine the engine does'nt rock about badly. This vibration is very rough as you go round a roundabout with power on and there is no vibration at all if going round a left hander under load. Might be worth changing it anyway. Don't think the engine mount costs too much. There is no vibration at all at the steering wheel so front tyres can't be the problem. More investigating needed.

cheers
 

·
Registered
Joined
·
229 Posts
Discussion Starter #8
Hi, come to mention it he said that the drivers side outer cv jont had play on it. He said that cv joints would ony make a knocking noise when bad and would not cause vibrating. The left side cv outer was replaced because it failed the mot.

cheers
 

·
Registered
Joined
·
38,877 Posts
I am pretty sure they can cause vibration if they are partly seized.

Normally they do knock when worn though.
 

·
Registered
Joined
·
229 Posts
Discussion Starter #10
Left the car in with alfa speciaist and he said that the vibration could be caused by wheels out of alignment and to get a 4 wheel alignment done. The thing is that the vibration only happens when accelerating or under load and when going right around a roundabout but if you lift off the vibration is gone. Its happening when driving straight as well if you are doing any speed and hit the accelartor it vibrates. If the alignment was out would'nt you feel something thru the steering wheel? There is no vibration or movement in the steering wheel and the steering wheel is alignment perfectly with wheels straight and there is no uneven tyre wear. Its a mystery and its spoiling the driving of the car. As i say the drivers side cv joint is gone but i'm thinking it has to be a driveshaft problem as it goes away as soon as you lift off accelerator.
cheers
 

·
Registered
Joined
·
5,621 Posts
did you solve this, i had a similar problem on a PT cruiser i had once, turned out one of the drive shafts had some play it it causing the vibrations under acceleration
 

·
Registered
Joined
·
6 Posts
have you sorted this yet?
i've got similar symptoms on my 2001 gtv. not noticed it going round corners but vibrating when accelerating & goes away when i lift off.getting worse as well.
 
1 - 14 of 14 Posts
Top