Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all,

My Alfa Romeo 159 saloon has developed a squeak on the front right in the area of the suspension.

I have replaced the top mounts, upper and lower arms and now the shocks but the squeak still hasn’t gone away. The anti roll bar links are in good condition as that was my next idea.

Has anyone got any ideas as to what this is?

Thanks in advance.
 

·
Registered
Joined
·
169 Posts
I had suspicions about suspension too when I had squeaks from the right side under the bonnert, but then came across a post here (cant find a link a the moment), which suggested spraying airbox resonator rubber mount with some silicon spray (lube) - fixed my problem instantly.
This rubber mount is placed inside V shaped metal mount and was squeaking on every road bump and when accelerating.
 

·
Registered
Joined
·
4,492 Posts
I had that on my 2.0....Silicone lasted about a week before the squeaking started again....so I glued a thin piece if rubber around it to make it a tighter fit in the bracket....quiet ever since.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Tha
I had suspicions about suspension too when I had squeaks from the right side under the bonnert, but then came across a post here (cant find a link a the moment), which suggested spraying airbox resonator rubber mount with some silicon spray (lube) - fixed my problem instantly.
This rubber mount is placed inside V shaped metal mount and was squeaking on every road bump and when accelerating.
Thanks!!
 
1 - 8 of 8 Posts
Top