Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter #1
The front speakers have been progressively getting worse over the last few months. I know it's in the flexi as you can move it about and make it work again but the problem is alfa in their wisdom put the flexi on the car loom side and not the door loom so how do you repair this without it turning into a total faff. :confused: if it was the other way round you could just take the door loom out and either swap it or repair it on the bench. This way you're stuck with fiddling in the small gap unless I take the while bloomin door off and even then it won't be easy.
 

·
Registered
Joined
·
4,094 Posts
i,m about to strip mine drills holes in them.. and run proper wires into the doors..

think its going to be fun but cant use the standard wires as they suck..
 

·
Vendor
Joined
·
45,441 Posts
i,m about to strip mine drills holes in them.. and run proper wires into the doors..

think its going to be fun but cant use the standard wires as they suck..
You mean using phono leads like you would for a subwoofer but for the door speakers?
 

·
Registered
Joined
·
4,094 Posts
nope using phono leads for the amps but need to run quality 6.3mm speaker wires into the doors to run focal components they require decent cable not the normal stuff supplied..
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter #6
i,m about to strip mine drills holes in them.. and run proper wires into the doors..

think its going to be fun but cant use the standard wires as they suck..
Hmm yes not a bad idea to run a new cable all the way through I guess
 

·
Registered
Joined
·
2,575 Posts
Are you sure it's not just tarnished pins in the round plug? :)
I had that problem with my 156 but after several cleanings with DeOx C, it came right.

-Alex
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter #8
Not looked yet as the ans has taken my attention but will try that first.
 
1 - 8 of 8 Posts
Top