Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
230 Posts
Discussion Starter #1
On my seemingly never ending quest to put my GTV perfect i find myself needing some advice,

last week i put my Bella in to the local Ford garage to have a wheel bearing replaced, i asked them to have a wee look at the front as i noticed whenever i turned right there was a clunk twang sound from the front, having changed the suspension arms and drop links i was concerned about what it could be, they said the suspension was all tight except the spring had slipped out of the rubber housing that the top sits in and would likely need replaced. they weren't great in explaining to me exactly what this part was.

i have begun to think it's this

http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=150980648810&ssPageName=ADME:X:RTQ:GB:1123

would i be correct?

also its MOT is soon and last year the advisory was for "play in steering rack inner joints" and it is quite bad now, lot of looseness in the steering, what am i looking at forking out for getting these changed?

Cheers Folks
 

·
Registered
Joined
·
919 Posts
I think your actual road spring (suspensions spring) has broken and lost a coil. Get yourself a pair of springs and have them replaced, or DIY; not too tricky for the average mechanically minded person.
 

·
Registered
Joined
·
230 Posts
Discussion Starter #3
I think your actual road spring (suspensions spring) has broken and lost a coil. Get yourself a pair of springs and have them replaced, or DIY; not too tricky for the average mechanically minded person.

If the spring had broken would the garage not notice that? and i'm not even a little bit mechanically minded so whatever it needs will have to be done by a garage lol.

Cheers
 

·
Registered
Joined
·
919 Posts
Not necessarily, sometimes the piece of spring is still there which is a dead giveaway but if not it can be hard to tell from a cursory inspection. From what they've said and the noise you describe I'm 99% its broken spring. They're rising rate springs, so the lower coils are slightly larger and spaced further apart than the upper coils. If the top coils broken off the lower coils will not fit into the top mount. Stand at the front of the car and see if it is sagging on that side, it should be lower if a coil or two are missing.
 

·
Registered
Joined
·
230 Posts
Discussion Starter #5
well just had a wee spy, can't really visually tell but i can barely fit three fingers between the n/s tyre and bonnet and easily fir three between the o/s tyre and bonnet so your theory may be correct, will have them double check this.
 

·
Registered
Joined
·
919 Posts
It's a very common failure TBH. I think I've changed at least one broken spring on every car I've owned since 1999 :rolleyes: Funny I never seemed to have a problem before then.
 

·
Registered
Joined
·
213 Posts
I had the same 'clunk' sound when fully turning the wheel. Once turned back, it clunked again. In my case it was the top mount bearing that was faulty, not a broken spring.
 

·
Registered
Joined
·
230 Posts
Discussion Starter #10
I had the same 'clunk' sound when fully turning the wheel. Once turned back, it clunked again. In my case it was the top mount bearing that was faulty, not a broken spring.
This is what the garage have also suggested as being at fault. Is the item in my original post the right item to rectify this?

Cheers.
 

·
Registered
Joined
·
708 Posts
It may just be the rubber mount that the spring sits in. If it's stretched and the spring has spun around in it, it will clunk as mine did. To cure it Neil (Italia Auto Parts) taped the rubber to the spring. Job done.
 

·
Registered
Joined
·
213 Posts
True, better make sure if you need the part at all. Better have your mecanic confirm before you order...
 

·
Registered
Joined
·
4,930 Posts
Top mounts do wear out.

I had this problem aswell. In my case it was that the spring had become unseated in the top mount. Nothing was broken. I replaced the spring with a standard height spring as i wasn't 100% sure the lowered springs were correct for the car.
 

·
Registered
Joined
·
230 Posts
Discussion Starter #16
It says on the report, top mount bearing worn so it will need replaced anyway.

Thanks for all your help guys.
 
1 - 16 of 16 Posts
Top