Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
507 Posts
Discussion Starter #1 (Edited)
Ok so in the ongoing leaking saga of 2011 I have just liberally applied some water to the windscreen and I discover that the water is coming down and thru the conduit of electrical cables that are directly above the accelerator pedal and disappear up into the dash heading for the windscreen guttering

So where do they emerge the other side?

Ps merry Christmas everyone!
 

·
Registered
Joined
·
304 Posts
Moel not sure if you posted your on going saga elsewhere but was going to suggest removing the windscreen scuttle panel (wipers off then the trim underneath) and have a look around under there. It could be a poorly sealed panel or where the loom enters the car from the bulkhead area.
To remove the scuttle panel there is a write up on this forum with step by step instructions to solve the famous rattle problem.
 

·
Registered
Joined
·
507 Posts
Discussion Starter #4
Ah Ha

Scuttle panel removed this morning, and it's fairly obvious that the rubber seal for the wiring loom has perished...in a rather large way. As there are tendrils of rubber, around one edge underneath the silver bracket that clamps it down...

Question is, how do i change it..it seems to be sealed 'around' the loom'

off to consult the elearn cd-rom bible
 

·
Registered
Joined
·
304 Posts
Moel, not sure if the rubber seal is a replaceable part, never had to replace one as they do not usually wear. Do you have any photos ? Only usual answer is a good quality silicone sealant like Dow and Corning ?
 

·
Registered
Joined
·
507 Posts
Discussion Starter #6
Will grab a pic tomorrow for you! I have to say..it doesn't look terribly user replaceable

I think black silicon might be the answer
 
1 - 6 of 6 Posts
Top