Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
833 Posts
Discussion Starter #1
Asi've posted over the last week my wife's 159 1.9 JTD (56 Reg) has been experiece power loss. Apparently the dealership in Leicester infrom me that it is a sticky Flow Shutter Valve or Sticky EGR. Apparently a common problem (read tyhe posts) on early models. Asked the dealership if a campaign had been run by Alfa UK to rectify early cars, she said no and confirmed that my car has been donee.

They want £30 for a diagnostic (bit steep for a 2min job) and then reccommend i contact Alfa UK to ascertain if they would be willing to recity the problem.

I also have a warranty from the garage i bought the car from.

Should i get the the Alfa diagnotics done and hope Alfa UK pay or should i go the warranty route and get Nationwide Auto Centre to do the work

Any advise greatly receivedd!
 

·
Registered
Joined
·
833 Posts
Discussion Starter #2
Any advise?

does anyone have the contact detials of Alfa UK Customer Services. I can't seem to find anything
 

·
Registered
Joined
·
847 Posts
Hi alfa999,
My 2.4 had the same problem and neither the EGR nor flow shutter valve replacement sorted it. There is a 3 hour 'service news' that the alfa dealer should run the car through to get it checked.
 

·
Registered
Joined
·
16 Posts
Hi alfa999,
My 2.4 had the same problem and neither the EGR nor flow shutter valve replacement sorted it. There is a 3 hour 'service news' that the alfa dealer should run the car through to get it checked.
hi can u contact with me, i'm having the same problem 2.4 thnx
 
1 - 7 of 7 Posts
Top