Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
618 Posts
Discussion Starter #1
A while ago I had a Pioneer F900BT fitted and it is great. Ipod control, video and the GPS work brilliantly. Plus you can you cna hack the GPS system to your heart's content (AVIC411.com is your friend), I've got the original iGo8, Primo, Garmin, TomTom and others working on the unit.

Anywho, one thing that has never really worked too well has been the radio, FM is just about there but MW and LW are completely dead. I figured out (with the help of the pages here) that the 159 needs an amplified lead for the radio antenna. Based on recommendations here I have bought the Connects2 CT27AA08 lead. My question is, how is it wired in? Where does the blue wire go? See piccie below. Cheers.
 

Attachments

·
Registered
Joined
·
618 Posts
Discussion Starter #2
To answer my own question : it hooks up to the power antenna connection on the HU loom... who'd a thunk?

In fact I didn't fit it as I thought I was going to have to go through the whole pull-the-fascia-off malarkey. Audiofile Incar in Bishop's Stortford did it for me. I mention them specifically because they did it for free - thanks! Needless to say, if anyone in east herts/west essex needs ICE, I would recommend them without hesitation.:thumbs:
 

·
Premium Member
Joined
·
7,579 Posts
Did it help ? I would have thought the 159 works the same as the other Alfa models, and just uses a separate power lead to the amp, not the superimposed (phantom power) type in your picture....
 

·
Registered
Joined
·
618 Posts
Discussion Starter #4
Did it help ? I would have thought the 159 works the same as the other Alfa models, and just uses a separate power lead to the amp, not the superimposed (phantom power) type in your picture....
It did help. I had poor FM reception and none in MW (which is annoying if Radio 5 is the only station you listen to...). Reception is spot on across the board now. There are a few threads here which say the same.
 
1 - 5 of 5 Posts
Top