Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Been down South on one of me semi-regular visiting sessions. Car ran sweet as you like the whole trip til I got halfway home and the windscreen washers packed up! Checked the fluid and filled it up with screenwash but I fear the problem may be a bit more serious than an empty bottle!
Have had a good look through the forum and found some good advice but, my mechanical knowledge is next to rubbish so, I'm taking it down to get it looked at tomorrow. Something tells me that warranty I bought could come in handy! Wish me luck!!!
 
M

·
Guest
Joined
·
0 Posts
Hi Stu. First of all I would check the fuses. We've had quite a few people coming in to my workplace with the washers not working and blown fuses are mainly the problem due to the cold/icy conditions.


Hope this helps.
 

·
Regional Support, For Lincolnshire - AOL
Joined
·
16,380 Posts
Could well be a fuse. I think that there may be a filter too, this could be blocked although I don't think this will be the problem.

Also check that the pipe from the pump hasn't come off, the one on my '6 did, I thought it was just frozen. What had happened was that the pipes had frozen and trying to pump fluid through solid pipe blew it off. Still it gave a good clean to the underside of the bonnet !
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
Took the car in earlier under warranty. One new washer motor later and all is well. Only cost £23 so can't really complain about that.
Took it to Nationwide Auto Centre on Tritton Road on warranty company's say so and must say they were very good.
 

·
Regional Support, For Lincolnshire - AOL
Joined
·
16,380 Posts
Took the car in earlier under warranty. One new washer motor later and all is well. Only cost £23 so can't really complain about that.
Took it to Nationwide Auto Centre on Tritton Road on warranty company's say so and must say they were very good.
Well at least it's working Stu.

Found out just now that the washer pipes on my '6 ARE frozen, just enough free space in the pipes to let it dribble out of the jets. :(

Still dribbling is good, it's a trait both me and the car have in common ! :wow:
 

·
Regional Support, For Lincolnshire - AOL
Joined
·
16,380 Posts
Haha....I know EXACTLY what you mean!!
:eek:

:lol:

Come along to the Ancaster Meet and we can have a synchronised dribbling event.........:wow:
 
1 - 7 of 7 Posts
Top