Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
So some *&*&&& wrote off my old porsche 944 cab and I fancied a change, With very little money in my pocket I found myself a nice low milage Phase 1 spider.
It was sold as seen and was a little unwell.
After sticking a new MAF and Lambda sensor on it it was still hunting at idle and popping up the check engine light.
I got myself a little usb diagnostic connector and made up some wire to connect it to the connector behind the radio.
I've puled off these error codes.
Read diagnostic faultcodes :
Bytes received: 0A 61 17 2B 40 08 71 17 2B 40
DTC: 0x0A = 10
state : 3
type : 0x01 Open circuit
condition1 : 0x17
condition2 : 0x2B
counter : 0x40
DTC: 0x08 = 8
state : 3
type : 0x11 unknown
condition1 : 0x17
condition2 : 0x2B
counter : 0x40
Bytes received: 2F 64 17 76 40
DTC: 0x2F = 47
state : 3
type : 0x04 Open/Short circuit at GND
condition1 : 0x17
condition2 : 0x76
counter : 0x40

I think they mean.
EGRV solenoid and Cam angle sensor. but I cant seem to find a list of codes for the old kwp71 interface for the ECU.

Appreciate any help. Thanks. Ben..
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
I discovered the wires were sheered through on the EGRV solenoid. after re-connecting them and clearing the errors the 0x2F went away. It appears the Cam sensor is dead, I stuck a scope on it and it's doing nothing so it looks like I'll have to take the pulley off and replace it :( .
 
1 - 2 of 2 Posts
Top