Alfa Romeo Forum banner

41 - 60 of 82 Posts

·
Registered
Joined
·
4 Posts
hello does anyone have a firmware to connect nav with a monochrome display because I have inserted 4.8 and the display does not work as someone has it to save my navi
 

·
Premium Member
Joined
·
7,298 Posts
hello does anyone have a firmware to connect nav with a monochrome display because I have inserted 4.8 and the display does not work as someone has it to save my navi
Did you originally have 26.xx (or 25.44) on your connect+, or 4.xx (or 5.xx)
The single/double digit versions cannot be exchanged, a version with originally 4.xx can f.i. only be updated to 5.xx, NOT 26.16, en VV.

There should be no difference between colour and B&W.
 

·
Registered
Joined
·
4 Posts
I upload 4.8 5.0 and the display does not work, I think I need to upload another one. but I've uploaded from Fiat 5.0 and the fiata logo appeared, but navi did not work, you have any other softy, and when I uploaded 26.16 it does not work at all and I do not know what was the original because I do not remember
 

·
Registered
Joined
·
4,107 Posts
I upload 4.8 5.0 and the display does not work, I think I need to upload another one. but I've uploaded from Fiat 5.0 and the fiata logo appeared, but navi did not work, you have any other softy, and when I uploaded 26.16 it does not work at all and I do not know what was the original because I do not remember
Youre a bit fooked then, you could dismantle it to find out which version it was, there is a difference, but its years since I ve had one so I cant remember what the difference are, you could try reading at the main Connect Nav thread here :

https://www.alfaowner.com/Forum/ice-andamp-blueandamp-me/51012-help-connect-nav-firmware-fiat-forum-knows-more-than-us-2.html

to see if the differences are mentioned in it.

Why the hell did you put Fiat software onto an Alfa ?? The Fiat ones use a completely different software and hardware (apart from the old Doblo and Ducatos which used a re-badged version of the 147/GT Connect Nav with reverse cam input added).
 

·
Registered
Joined
·
4,107 Posts
There should be no difference between colour and B&W.
Youre wrong there jwq - the monochrome (black and red, not black and white) Connect Nav versions have a smaller screen and totally different software to the colour (Connect Nav+) versions.
 

·
Registered
Joined
·
4 Posts
Hello, I installed 5.0 mp3 from the net and wrote to 147 and it turned out that to fiat I got back to 4.8. The radio is just a night on the display, not just lights up, as I wrote earlier, there must be other software you know where you found them? And so out of this I still have one more navi + from 26.16 but I would like to add some other one, which means older, soft because it is mulching and stuttering. has someone like that
 

·
Registered
Joined
·
9 Posts
Hi guys!
...
Сan I have the 26.16 firmware(ENG) for my Alfa 147(2002 year).
...
Sent....
Thank you for sending, but I looked at my mail, there is no message from you yet. You sent by mail?

Hi there, please can you send to me as well? I am having a nightmare - bought a replacement head unit after mine packed up and alfa won't supply me with the master code for it! If heard a software update will resolve the issue? [email protected]
Thanks in advance, much appreciated.
 

·
Registered
Joined
·
5 Posts
Hey guys, I would very much appreciate it, if you could send me the files for the firmware 26.16 for my 2002 Alfa 147 Connect Nav+ to my email [email protected]. Thanks a lot!

If I understood correctly, 26.16 is compatible with the 1st generation Connect Nav+ (till 2004 or 2005), am I right?
 
41 - 60 of 82 Posts
Top