Alfa Romeo Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
640 Posts
Discussion Starter · #1 · (Edited)
Lately I was having crazy black smoke clouds, so I started hunting the leak.
After some testing, it was the intercooler:

Then I checked the turbo play, seems great for 561K km (348K miles):

Saw some oil, which is normal, made a small test, running without intake, it made some oil aerosol... The car had run 1h ago so it couldn't be some oil deposits from being parked.
But I was thinking, there's no boost with open output, while normally there would be 1.5bar, pushing the oil inside and probably reducing the leak.
My car never throws blue smoke or smells like burned oil, neither I had an excessive oil consumption (Well, since a month ago it does, but it's a leak in the oil cooler, seems like cracked o-ring), not even the usual blue smoke puff after few days stopped, like leaking turbos do.

As kind-of-compression test, I blocked the pcv output, so all the engine fumes went through the oil cap.
No typical puffing like when a piston is bad, it's a continuous output, slightly pulsed from the camshaft rotation, doesn't seem be anything wrong.

Finally, I checked the intake manifold. Is absolutely spotless.
I cleaned it 5 years ago and dumped the EGR somewhere out of the car :LOL:


The clapping noises are the dmf, been doing that since 4 years ago, f** it while it works!

For now I'm just searching a new intercooler... Just wanted some feedback about the tests!:)

Thanks!
 

·
Registered
Joined
·
640 Posts
Discussion Starter · #2 · (Edited)
Intercooler replaced, leak gone, still smoking badly when flooring it.
Yet to check the turbo oil return pipe, I'm pretty sure it collapsed, causing the turbo dumping the oil into the intake.
The oil will get burned in the engine eaily as the turbo atomizes it very finely... then there won't be enough oxygen left for the fuel!

Today I made a compression test. Not in the mood of removing the injectors, neither paying 30 quid plus shipping for the lasertools empty glow plug, I made my own.
All cylinders had 400psi, so I guess it's in great shape with 562.00km!


 
1 - 2 of 2 Posts
Top