Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
Hi guys. This is a question for those in the know about turbos. I've got an horrendous squeal coming from the engine bay when the car is cold. It increases with revs but it dissappears when the engine is hot (well at least it used to, fairly certain in comes back if you haven't been giving it the beans!). It sounds like air being released from a balloon. I've read on here that it could be manifold/gasket related..... but someone has put the fear of God in me and said it could be turbo related.

My question is, could it be the bearing or the cartridge that needs replacing. If that is the case is there a standard cartridge used on these turbotechnics hybrids???
 

·
Registered
Joined
·
121 Posts
Tear in turbo hoses, in addition to the other two suggestions. Upper on my 1.9 mjet caused a screeching at times, was convinced it was a belt.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #4
Sounds more like a pulley than a turbo ..
Already had the belt off as it was looking very tired and the pulleys were checked at the same time, still made the squeal with the belts off. Heres hoping its a hose then! Only had the car about a month and Im spending a small fortune! :smash:
 

·
Registered
Joined
·
2,757 Posts
Ok.

Boost side of induction is next most obvious culprit then..

Lower hose being the first place to look as especially with a hybrid the boost pressure will be high and in addition quite hot..does the car have a front mounted intercooler or the original oem one? I ask because if its a fmic then multiple places where you could have a boost leak coming out under pressure.

After you have ruled out all of this then it may be time to look at the turbo. TBH its a bit premature to suspect it just yet.

Any excess smoke out the back?
 

·
Registered
Joined
·
248 Posts
Discussion Starter #6
Ok.

Boost side of induction is next most obvious culprit then..

Lower hose being the first place to look as especially with a hybrid the boost pressure will be high and in addition quite hot..does the car have a front mounted intercooler or the original oem one? I ask because if its a fmic then multiple places where you could have a boost leak coming out under pressure.

After you have ruled out all of this then it may be time to look at the turbo. TBH its a bit premature to suspect it just yet.

Any excess smoke out the back?
Still OEM, FMIC is on the list but not quite at the top, No black excess smoke. Looks like i will be out with a spray bottle tomorrow or the weekend :)
 

·
Registered
Joined
·
2,757 Posts
ok..re the intercooler ,two things.

1) stock one may be leaking.

2) I may have a very cheap UK based option for this which will come in at under £200 for the whole kit...IMO GT/157/147 specific kits are horrendously expensive for what they are. will keep you posted.

the no smoke is not so good as boost leak normally leads to the car running rich..


Turbo would still not be my first port of call on this though,do me a favor, put the car in neutral and slightly depress the clutch, does it make ''the noise''..if so clutch release bearing ..thats both good and bad news as it means


A) your turbo is fine..:thumbup:

B) your gearbox needs to come out to change the clutch release bearing, might as well do the clutch and fly whilst your there if not done recently and obviously slave cylinder...:depressed:

let us know what you find.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #8
ok..re the intercooler ,two things.

1) stock one may be leaking.

2) I may have a very cheap UK based option for this which will come in at under £200 for the whole kit...IMO GT/157/147 specific kits are horrendously expensive for what they are. will keep you posted.

the no smoke is not so good as boost leak normally leads to the car running rich..


Turbo would still not be my first port of call on this though,do me a favor, put the car in neutral and slightly depress the clutch, does it make ''the noise''..if so clutch release bearing ..thats both good and bad news as it means


A) your turbo is fine..:thumbup:

B) your gearbox needs to come out to change the clutch release bearing, might as well do the clutch and fly whilst your there if not done recently and obviously slave cylinder...:depressed:

let us know what you find.
I believe Loz did the gearbox check recently as it went in for a health check recently (Loz wasnt sure of the noise). Ill double check when I finish work. At least it would only be the clutch to change, SMF fitted already :)

The squeal seems to stop so im hoping that its a pipe sealing as it heats up. I dont push the car hard when its cold so that may be why i dont see any smoke???
 

·
Registered
Joined
·
555 Posts
One of the exhaust manifold's screws could have also sheared and now the manifold doesn't seal properly until it's hot. Not very common on a 1.9 but not unheard of either.
 

·
Registered
Joined
·
2,757 Posts
Its a mystery for sure.

Lets hope its manifold bolt or something cheap and silly.

Fingers crossed for you..

BTW this is why I went the route of doing it all myself rather than buying an "out of the box" modified GT. I can be sure of the quality of the work and the overall condition of the vehicle prior. Still no Guarantee it wont bite me on the backside at some point of course but it does minimise the chances of it happening.

Hybrid should be good for 100k if there are no issues with oil feed or contamination so if it is the turbo I would not re-furb and replace until you have a reason as to why it has failed and have rectified it.

That it goes away when warm does suggest there is an expansion element to it. So exhaust orinlet mani are implicated too..
 

·
Registered
Joined
·
248 Posts
Discussion Starter #11
Binji I read that somewhere as well - Im kinda hoping the exhaust manifold is the cause (Ive already brought a new gasket just in case).

Id love to have gone down the route of modifying from start to finish but this came up at a decent price and once id sold my other it gives me a few quid to spend on it. New oil and filter are ready as well just in case the oil is old (only had the car about a month, so at least when its changed i can start with 6 monthly changes). It would be interesting to see how much a turbo refurb would cost though!

Joey - Is that intercooler option just for the SMIC?
 

·
Registered
Joined
·
2,757 Posts
Binji I read that somewhere as well - Im kinda hoping the exhaust manifold is the cause (Ive already brought a new gasket just in case).

Id love to have gone down the route of modifying from start to finish but this came up at a decent price and once id sold my other it gives me a few quid to spend on it. New oil and filter are ready as well just in case the oil is old (only had the car about a month, so at least when its changed i can start with 6 monthly changes). It would be interesting to see how much a turbo refurb would cost though!

Joey - Is that intercooler option just for the SMIC?
no its for the FMIC, watch this space..:thumbup:
 

·
Registered
Joined
·
248 Posts
Discussion Starter #14
Waterpump, cambelt idler or tensioner pulley bearings don't seem to have had a mention yet.
Cambelt, tensioner and water pump are about 4k miles old. Hopefully its not them yet.......I know the cambelt needs to be changed regular but ..... :jester: lol
In all seriousness though its definitely worth a thought. I dont think it was a cheap belt kit that went in either. So fingers crossed I can rule that out for the time being. What does worry me now I think about it is the guy i brought it out was "tweeking" the turbo actuator before I picked it up...............
 

·
Premium Member
Joined
·
1,742 Posts
Was the outer belt done at the same time, accessory belt ? If so, I had a squeal after mine were changed, took some time to locate the cause, it was the new outer belt, cheap brand. New dayco item fixed it.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #16
Outer belt is even newer. Car was run without the belt, so no pulleys moving. Still had the noise.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #17
Finally had the squeal sorted yesterday. It was a missing exhaust stud, bottom right. Had the head tapped and a slightly larger bolt put it. The neighbours no longer hate me in the morning! :)
 
1 - 17 of 17 Posts
Top