Alfa Romeo Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
810 Posts
Discussion Starter · #1 ·
Had a few issues lately where car didn't quite sound right on tickover, sounded a bit rough, and occasionaly mcsf would flash on and off. Then more recently mcsf came up and stayed on. Multiecuscan gave the following errors (see next post for picture)....

P1135 - states this is 'fatal', should I be scared??
P0300
P0304
P0305
P0306

I'm thinking these are all linked, but where should I start with the investigation? Lambda's? Coil packs? Injectors? Wiring? Something else?
Cylinders 4,5 & 6 are the rear bank aren't they?

Cheers for any advice
 
G

·
The lambda sensor on that bank is shot.

The preheat is the lambda heating coil being buggered. The cylinder misfire errors are the ECU getting dodgy readings from the lambda sensor and deciding that one of the cylinders feeding that sensor is misfiring to give the error. As it doesn't know which one, it has given the error on all 3.

New lambda sensor, or fix to maybe broken wire should sort you out.
 

·
Registered
Joined
·
4,775 Posts
I had very similar codes - but to the rear bank. It turned out to be a fuel flow problem; silly bo**ocks me had twisted the fuel hose to the rear bank on reassembly and severely restricted flow. It ran OK at very low revs and low load but mis-fired as soon as my foot went down.

The lambda did throw up a fault but that is to be expected when she's not running on all six.
 

·
Registered
Joined
·
2,541 Posts
Bosch sensor from eurocarparts was £47 for me. The start checking the misfires. If it was rear bank i would be more concerned
 

·
Registered
Joined
·
4,775 Posts
If you have a mis-fire unburnt fuel will enter the manifold and the sensor will throw up a fault, I did get mine changed but it didn't solve the problem, only a new fuel line cured mine (because the internal fuel line was twisted much to my embarrassment).

Rob
 

·
Registered
Joined
·
810 Posts
Discussion Starter · #9 ·
Ok so back to this one, changed the front bank lambda sensor pre cat (bosch) and was ok for a while, but errors are now back. Although sometimes I just get the pre-heating error, but I think that's just if I catch it before I give it time to set all the misfire errors off. Should I check the lambda wiring next or any other suggestions?
Cheers
 

·
Registered
Joined
·
810 Posts
Discussion Starter · #10 ·

I am still having these issues with fault codes. So far have:
*changed both front lambda sensors - bosch
*found a small leak on front bank lambda boss - welded up
*found a pretty big crack on front bank cf2 manifold - welded up for now (have just won a new set on ebay tonight)
*lambdas all tested and showing as operating correctly
*coil packs tested as working ok
*compression tested on all units (all between 180 - 185 psi)

recently also had a misfire on #6 cylinder, car wouldn't accelerate properly. Found a dodgy connector to the injector. That issue now sorted.

Next plan is to check fuel pressures and possibly injectors removed for cleaning, and fit new (uncracked) front bank manifold. Also tempted to check timing as I believe there were issues with this after its last belt change before I bought the car......
Also, my front lambda's are in the downpipes (Gotcha's) as opposed to the manifolds, could this be contributing to my issues? Tho I'd have thought both banks would have the same problem if so?

The MCSF/engine light used to come on and stay on every time I drove the car, now its only every so often and then might stay off for a couple of days?

Anyone else had similar problems or any ideas??
 

·
Registered
Joined
·
854 Posts
I'm having mine checked tomorrow.
I have P0300 to P0306.

Am guessing fuel lines or lambda or cracked something......
Will be interested to hear what you find, keep us informed. Will be in Singapore myself later this month (for work)

Drop me a pm and we can catch up with the Motley crew of GTA and 3.2 owners here. Our 3.2 population has dwindled to just about 10 ish now.

Just sent my car in and will await the diagnosis by the end of the day
 
1 - 14 of 14 Posts
Top