Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
278 Posts
Discussion Starter #1
Morning amici,

I have an small issue that's been bugging me for ages and I can't figure it out.

Every so often on my 1.9jtdm 159SW my idle is high, between about 900 and 1200rpm, but, it's doing it whilst driving. If I'm cruising along at pretty much any speed and drop the clutch it will float around the higher rpms. (Like in old cars if you pulled the choke out). I can also feel that it is down on power when it's doing this and a bit lumpy if I give it the beans.

I have:

Blanked and fixitstan'd the EGR
Removed and fully cleaned all of the injectors
Run loads of injector cleaner through for the past couple of months
Serviced every 6 months at the most with decent oil
New turbo about 4 months ago

Any ideas would be appreciated as I am stumped.

Matt
 

·
Registered
Joined
·
4,802 Posts
Could it be doing a regen at the time? (check the MPG when it is happening, is it particularly high?).
 

·
Registered
Joined
·
62 Posts
Yeah, forget about that. Better to have some basic diagnostic with MES and check DPF, that could be before death., and doing regenerations every 100-200km.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #5
Cheers guys,

Injector 4 is a little high compared to the other 3 even after taking them all out and giving a session in the ultrasonic bath, I'm not on my laptop so I haven't got the live run data to hand, but IIRC it maxs at about 2.1.
Giblets, it's not linked to the regens as it did one this morning but the tickover was fine. Regens are every 500 - 700 miles.
Belts have been changed about 15k miles ago.
 

·
Registered
Joined
·
7,556 Posts

·
Registered
Joined
·
62 Posts
I was reading some topics in our local alfa romeo forum, and it´s looking 99% like DPF regeneration.

Many owners of 159 confirm that while DPF regen they idle RPM are +- 1000rpm.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #8
It's definitely not a regen, I know when it's doing those (boost drops off throttle, high tickover etc) It's done it for as long as I've owned it even before I changed the belts.
 
1 - 8 of 8 Posts
Top