Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6,693 Posts
Discussion Starter #1
Finally gotten round to changing my coolant tank, but for the life of me, I can't remove the bottom hose clamp.

Anyone know how...?


Its part number 71714114
 

·
Registered
Joined
·
2,336 Posts
I don't think these clamps are reusable - they are not the type that normal clamp pliers will remove. I had to destroy the clamp on mine to get the hose off and replaced with old fashioned jubilee clip.

I trust you mean the clamp that is on the hose that exits the bottom of the expansion tank and not the bottom hose on the engine.
 

·
Registered
Joined
·
2,336 Posts
PS: where did you get the tank and how much? It looks to me as if the 156 tanks are identical but seem to be cheaper. My son's 147 could do with a replacement tank as the old one is really cruddy and the tank separators make it impossible to get spotless.
 

·
Registered
Joined
·
6,693 Posts
Discussion Starter #4

·
Registered
Joined
·
6,693 Posts
Discussion Starter #5
I ended up hacking it off, and replacing it with a jubilee clip. All sorted now, and I can actually 'see' the coolant level... Bonus :thumbup:
 

·
Registered
Joined
·
4,772 Posts
I replaced the original 10 year old tank with a non-OEM ebay tank; it lasted 16 months before developing a pin hole and spraying the engine in coolant. Apart from the pin hole the tank had swollen noticeably. Needless to say I've got a genuine part now. The difference as far as I can see is that the seam around the tank is much thicker and as a result the tank is stronger resisting the pressure.
 
1 - 7 of 7 Posts
Top