Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I recently changed the EGR cooler (fun job), put everything back to normal. Couple weeks ago.

Since then, 3-4 times I get "Excessive radiator fluid...Stop engine" Temp gauge hits maximum. I pull over.

Bonnet open. Coolant is gushing everywhere, seems to be forcing itself out where the hose clips are. They're on tight, but still, its forced out. I leave the car for a bit. Temp goes back down. Car calms down. When its cool again I check the fluid levels. They need a top up...I make very sure I don't go over 'max'...few days later it happens again. Fluid everywhere. Forcing itself out. I didn't over fill in the first place either.

What is this all about??? It's like it thinks its too hot or something. Any ideas would be a great help. Thanks!
 

·
Vendor
Joined
·
46,244 Posts
Are you sure your hose clips are good? Maybe the thermostat is stuck shut, maybe you have an air lock, maybe the new EGR cooler has something wrong with it.

If the ECU says the coolant is getting too hot, then it is very likely correct, at least at the point where the coolant temperature sensor is installed.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Are you sure your hose clips are good? Maybe the thermostat is stuck shut, maybe you have an air lock, maybe the new EGR cooler has something wrong with it.

If the ECU says the coolant is getting too hot, then it is very likely correct, at least at the point where the coolant temperature sensor is installed.
Thanks for the quick reply! I'll check those things now and see what I come up with. Hope cooler isnt faulty!
 

·
Registered
Joined
·
565 Posts
Not sure about 1.9 but on my 2.4 I had to top up the coolant each day for a couple of weeks even after venting through the plug. It's now fine and has not used any coolant for about 3 months. I'd try topping up each day to just over max and making sure it doesn't go below min. then hopefully all the air will work it's way out of the system in a few days.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
Thanks for the replies. I've bled the radiator, there was some air in there. Topped up coolant again and left engine to warm up to normal. Went for a spin. So far so good. But can't be that easy..Can it?

I hope its not head gasket..I'll check the oil...
 
1 - 8 of 8 Posts
Top