Alfa Romeo Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
15,172 Posts
Discussion Starter #1
Do all 147s have ESP or was it an option?
I'm not talking about ASR or ABS, which mine has in addition to ESP.
If it's what ALfa call VDC, then it isn't called that on the dash when it flashes up a failure message in the cold recently (new battery required I think...).
 

·
Registered
Joined
·
656 Posts
Not all Cars had ESP/VDC( I Think)

They are both the same.VDC is Alfa version of ESP(Electronic Stability Program)

Personally i would not change the battery just yet,as the cold weather is causing alot of intermitent fault codes. Should clear up hopefully
 

·
Registered
Joined
·
28,482 Posts
Can't remember seeing ESP on mine, I must admit, but there again, I didn't look for it before !!!!!.......:rolleyes:
 

·
Registered
Joined
·
15,172 Posts
Discussion Starter #4
I've read a few threads about a low battery causing ESP/ABS failures and when mine flashes up an error, it's just the ESP system (and ASR) that switches off. ABS still functions fine so the sensors are OK.

I've also been getting a dimming of my headlights when changing gear also when the ASR/ESP kicks in which makes me think it could be that.
 
N

·
Guest
Joined
·
0 Posts
VDC:

All 2.0s had it. (So therefore all Selespeeds.)

Option on the 1.6 (or by trim level)

Low power 1.6 never had it.


Dunno about the DERVs.
Probably all had it with that big hunk o' pig iron under the bonnet.



Battery would be the 1st port of call.

When did you get a Sele? :confused: :thumbs:
 

·
Registered
Joined
·
15,172 Posts
Discussion Starter #6
Battery would be the 1st port of call.

When did you get a Sele? :confused: :thumbs:
I'll get it tested. :thumbs:

About a month ago. During your unathorised leave of absence, my 166 was stolen. :(
Still waiting for an insurance payout - they're playing silly beggars and saying I'm not covered. :rolleyes:
 

·
Registered
Joined
·
6,811 Posts
my 1.6 lusso had em all, ebd, abs, esp, asr, it was a limpet:lol:
 

·
Registered
Joined
·
1,425 Posts
My 147 2.0 lusso DEFFO has ESP!

It knows when it has upset me that I going to shout at it and sorta behaves itself! :rolleyes: :rolleyes:
 

·
Registered
Joined
·
6,811 Posts
Does the 156 have any kind of traction control.
only the mk1 face lift and the mk 2's. mines got ebd,abs,esp and asr:thumbs:
 

·
Registered
Joined
·
15,172 Posts
Discussion Starter #15
I was at Bearings this morning to get a minor water leak sorted out and got them to test my battery. Instant result on their Marelli tester - "Replace Battery".
Bosch S3, Euro Car Parts - £53. I'll swap it out this afternoon and see if it cures the error (and my dimming lights!).
 

·
Registered
Joined
·
15,172 Posts
Discussion Starter #16
Swapped the battery yesterday and this morning I got an 'ESP System Failure' so it hasn't solved it. It generally happens just as I steer and put apply a touch of throttle. Possibly after releasing the brake but I'll need to wait for it to happen again to confirm that.

I did an Alfadiag ECU error code scan last week and I got 37 instances of cruise control error - Implausible brake pedal signal (or similar, I can't recall the exact terminology). Related?
 

·
Registered
Joined
·
15,172 Posts
Discussion Starter #19
It MAY need the faults clearing from the Black Box?
I don't know if that is the case but I've cleared the engine ECU faults with Alfadiag.
I have downloaded Fiat ECU Scanner to connect to the ABS ECU which I will do tonight.
 
1 - 20 of 24 Posts
Top