Alfa Romeo Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all.

I'm a proud owned of a 2017 QF, and really do love the car, however, I have an issue.

The car will randomly flash up all the following errors at once when starting the car :-
- Red seatbelt error
- Amber Collision warning light
- Amber Electronic handbrake warning
- Red airbag error

I had the dealer look at it (Snows in Southampton) and they replaced the battery and updated the infotainment. It seemed to be fixed but 2 days later they appeared again.

Yesterday the Seatbelt alarm chimed the entire journey!

It's a massive pain for me to get the car to the dealer so want to try and get some ideas off you guys first.

Anyone else had any experience of this?

Thanks in advance...
 

·
Registered
Joined
·
351 Posts
Difficult to diagnose... but check the battery voltage again should be around 13V when off and around 14.5V (charging) when engine is running, also check if the current drain is excessive when the ignition have been off for a few minutes.

It could also be a bad earth connection somewhere in the engine bay.
 

·
AO Detailing Car Of The Year 2020 Winner
Joined
·
4,008 Posts
Difficult to diagnose... but check the battery voltage again should be around 13V when off and around 14.5V (charging) when engine is running, also check if the current drain is excessive when the ignition have been off for a few minutes.

It could also be a bad earth connection somewhere in the engine bay.
The battery usually only reads approx 12v after a few mins of all systems off. It's not easy to confirm battery State of Charge by voltage but may give an idea. Did the dealer check the battery and the body computer? If not they need to.

Edit: just noticed dealer replaced battery. So it sounds like it could be Body Computer as don't think some of the warnings OP is having are normally seen with a battery issue.
 
1 - 6 of 6 Posts
Top