Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I am looking to buy a certian Giulietta 1.4tb 120hp 2014. I posted a query previously here on the forum about the rubbing noise in the engine. Now after giving it few more test drives I noticed other things and I'd like to ask other 1.4 TB owners to confirm if these things are normal and happen with their car as well.

When starting the engine, it runs at 750 RPM and the engine vibrates a lot then after 30 seconds or so the engine revs go up to 1000 RPM and the vibrations stop. This happens if staring engine hot or cold. Is this normal? What RPM should it run on idle?

Also during the test drive the revs were fluctuating when stopped in trafrice (up and down every half a second) I don't think that's normal is it?

There isn't many videos online of 1.4TB 120hp engine sounds, could someone upload a video of the engine sound with the hood up? I would really like to compare what its supposed to sound like. There isn't many of them on the market in Ireland so I have nothing to compare.

Thanks!
 

·
Registered
Joined
·
874 Posts
It could be normal.
On a standard transmission, there is an electronic which has the revs at about 750/800rpm with the clutch completely pressed.
When you lift the clutch slightly, the revs go up to about 1000rpm.

If you were depressing the clutch right at the switch point, you may have provoked the erratic rpms yourself.
 

·
Registered
Joined
·
200 Posts
Could be 1 plug not firing at first and then cutting in later, bringing the revs up. Could be a plug, coil or the connection on top. Do you know when they were last changed?
 

·
Registered
Joined
·
2,353 Posts
It could be normal.
On a standard transmission, there is an electronic which has the revs at about 750/800rpm with the clutch completely pressed.
When you lift the clutch slightly, the revs go up to about 1000rpm.

If you were depressing the clutch right at the switch point, you may have provoked the erratic rpms yourself.
Is that just on the 120?

My 170bhp manual doesn’t not do that.

Cold start rpm around 1000 then once warm settles around 800-850 and remains like that with clutch in or out and after starting back up when warm.
 

·
Registered
Joined
·
37,146 Posts
A rubbing noise could be a cambelt issue. Sometimes on some cars if a tensioner fails the belt can rub against the cambelt cover until it gets thin enough to snap.

It would certainly need further investigation.
 

·
Registered
Joined
·
874 Posts
johnnyroper
it may be a multiair feature. My 150 does it, the 170 of a friend also does it.
Maybe it only came with the face lift.
 

·
Registered
Joined
·
1,862 Posts
Isn’t hunting / fluctuating revs usually to do with airflow and spark issues?

If you can, try test driving another one? See how it compares.
 

·
Registered
Joined
·
330 Posts
A lot of (most?) modern cars will do the clutch up/rev increase. It's a sort of anti-stall feature that allows learners (and others) to lift the clutch gently in first with no throttle and get moving.
 

·
Registered
Joined
·
37,146 Posts
A lot of (most?) modern cars will do the clutch up/rev increase. It's a sort of anti-stall feature that allows learners (and others) to lift the clutch gently in first with no throttle and get moving.
I think it is something to do with the fact that engines run very lean at idle (for emissions purposes) which makes the raising of revs when the clutch is pressed necessary.
 

·
Registered
Joined
·
16 Posts
I am looking to buy a certian Giulietta 1.4tb 120hp 2014. I posted a query previously here on the forum about the rubbing noise in the engine. Now after giving it few more test drives I noticed other things and I'd like to ask other 1.4 TB owners to confirm if these things are normal and happen with their car as well.

When starting the engine, it runs at 750 RPM and the engine vibrates a lot then after 30 seconds or so the engine revs go up to 1000 RPM and the vibrations stop. This happens if staring engine hot or cold. Is this normal? What RPM should it run on idle?

Also during the test drive the revs were fluctuating when stopped in trafrice (up and down every half a second) I don't think that's normal is it?

There isn't many videos online of 1.4TB 120hp engine sounds, could someone upload a video of the engine sound with the hood up? I would really like to compare what its supposed to sound like. There isn't many of them on the market in Ireland so I have nothing to compare.

Thanks!
No doesn’t sound right at all. I have a 1.4 tb with a cold start it’s around 1000 rpm no vibrations on tick over. After a few minutes as it warms up it’s around 750rpm on tickover with no vibrations.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #15
Thanks for your help guys! The revs go up from 750 to 1000 every time after starting the engine without pressing the clutch, seems like it is an abnormality in this car.

All these little things with the engine make it seem like the car isn't worth the money. Especially because it's a main Alfa dealer selling the car so it should be top notch.
 
1 - 16 of 16 Posts
Top