Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
345 Posts
Discussion Starter #1
Hello,

I swapped my 155 V6 for a 156 2.0 TS a couple of years ago, and now it's done 60k it's beginning to exhibit a few undesireable tendancies. One is a 'diesel' like noise on start-up, which I have heard is due to the 'variator'. What is this, and is it a difficult job to fix?

Thanks,

Brian King.
 

·
Registered
Joined
·
2,136 Posts
It is the variator, yes. Same thing was happening to my 2.0TS 147 at the same mileage. Was fixed as part of a 72k service.

The part is around £100 plus whatever your garage will charge per hour to fit it.

As for exactly what it does.......something about low-rev torque, I think, but someone elsewhere on this site will know more!!! Welcome.
 

·
Registered
Joined
·
345 Posts
Discussion Starter #4
Many thanks,

I'll trawl through the forum becasue I expect someone will have asked about this before.

Regards,

Brian King.
 

·
Registered
Joined
·
2,136 Posts
Brian, you'll feel better performance once it's fixed. When I got my 147 back from its last service, having had the variator replaced, it pulled so much better low down in the range - acceleration that had slowly disappeared over time was suddenly rediscovered. Great feeling.

Apparently the variator 'adjusts the timing of the inlet camshaft' but I read that somewhere, and don't know what it means :)
 

·
Registered
Joined
·
345 Posts
Discussion Starter #8
Thanks everyone,

Yes, it is lacking bottom-end pull. I've booked the car in with Jamie Porter to get it fixed.

Best regards,

Brian.
 

·
Premium Member
Joined
·
38,310 Posts
Welcome to AO. :)

Good luck with your Alfa. :D
 
1 - 10 of 10 Posts
Top