Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
The problem appeared recently. After overnight stop when in the morning starting the engine for the first time the starter is turning much longer than usual. Sometimes after this longer turning when engine finally ignites it runs for a few seconds erratically as if it would receive not enough petrol. Later during the day the problem does not occur. The engine starts normally after short starter turning and runs smoothly.

Battery and starter's bendix were changed less than 2 years ago. Spark plugs were changed recently but before change the problem has already existed. Till now I have covered with Alfa (since new) about 206 000 km (128 750 miles).

I reckon that maybe fuel pump is starting to fail as since this problem occurred it is working louder and it may not give enough fuel pressure when cold starting the engine after overnight stop. What do you think?

Engine: 1.6 TS 120 HP
 

·
Registered
Joined
·
2,537 Posts
Possibly a dribbling injector or similar on your fuel line. I had a similar issue. Took much longer to start due to it not holding the fuel. When left to sit for a while.
 
G

·
Guest
Joined
·
0 Posts
There is a guy on eBay who supply's 4 sonic cleaned injectors new seals ready to fit for £60.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #4
The interesting thing is that when I start the engine with fuel tank full or almost full the problem does not occur. So maybe this is really fuel pump failing?

I will have to check with Multiecuscan fuel pressure on fuel pump while starting the engine...
 
1 - 4 of 4 Posts
Top