Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
hi, i think it maybe the EGR valve,but tell me what you think, the last 2 days after about 1 mile ,engine stil warming up,i get the beep beep on the info display , and reduced power on the revs, when the engine is warm theres not a issue, i just turn ignition off and on it then clears,is there any way of getting the codes out with out a obd2 reader ? and how can you reset the service expired warning, after i have just done a full service, thanks guys
 

·
Registered
Joined
·
2,012 Posts
i don't think you can check codes without a plug-in jobbie of some description.

EGR is usually reduced power and lots of smoke from the exhaust at lower revs under large throttle. You could have MAF or MAP or other issues here and it may well need plugging in....

However IF you think it's the EGR, look up the strip down and service "how to" - the solenoid can corrode and stick and this shows you how to sort it. Cheaper than a replacement. Obviously clean out the "dirty" side as well...

Hold down the + and - buttons either side of the info button to reset the service interval. I think the schedule mileage has to be showing on the info unit.....

HTH!

"plug-in jobbie" is not to be misinterpreted! :D
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
thanks for that reply photoman, i noticed today it only did it once today, when going down the motoway, and theres no smoke or unusual noises, just reduced power and i think limp home mode,
 
1 - 3 of 3 Posts
Top