Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi All,

As the title suggests, i have the dreaded code on my Brera at 53k miles. I have tried the following solutions as first the error message read:

Phase sync- Exhaust cam (total oil and filter change and engine flush) and replaced exhaust solenoid.

This was fine for 2 weeks, then the EML came back on reading: Phase sync inlet/revs. Replaced inlet variator solenoid. Same again but EML has come back on a few days after.

Car drives perfectly and Grahem at Motori Penzance has been brilliant. is there anything else to try before replacing the timing chain? The error codes always come on seperately and can stay on for 2/3 days then go for 2/3 days.

Any help would be great.
Thanks
 

·
Registered
Joined
·
1,066 Posts
Given the history of timing chain problems at around your mileage I would guess it's going to need changing. I've had 2 Brera 2.2's and both have had the timing chain done...
 

·
Registered
Joined
·
7,554 Posts

·
Banned
Joined
·
3,110 Posts
It is a chain issue. No further discussion.
It could be discussion for gurutechs wheither it is chain stretch or chain over- spin would result which parts to be replaced and which are not. Just do it complete to be a user.
I wonder car still drives perfectly. Normally it is not.
I also wonder why P0016 initiate solenoids replace message.
Could be a reason that two phase sensors have died both together same time, but I can hardly believe it.
Good luck...
 

·
Registered
Joined
·
7,554 Posts
I wonder car still drives perfectly. Normally it is not.
Mine drove perfectly with P0016, right up until I got it changed.
If the EML hadn't come on, I wouldn't have known there was an issue.
Hence why I didn't rush to get the work done.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Lusso- did you error code read the two different options or both at same time? Iv'e only ever got individual error codes, never at the same time.
 

·
Registered
Joined
·
7,554 Posts
I can't remember the exact wording when the code was read, but my mechanic said straight away it was the chain.
There was never any mention of solenoids. He'd done them before on countless old Vectras (same engine).
My research at the time (and what I've read since) backs this up. P0016 is definitely the chain.
 

·
Banned
Joined
·
3,110 Posts
Mine drove perfectly with P0016, right up until I got it changed.
If the EML hadn't come on, I wouldn't have known there was an issue.
Hence why I didn't rush to get the work done.
Could be just an impression.
My car is equipped with direct flew exhaust system.
While P0016 car has sounded louder enough than has driven enough.
I had P0016 every first car start just after code erase.
:depressed:
 
1 - 8 of 8 Posts
Top