Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
driver side window is stuck down, switch is dead (no clicks up or down) passenger side switch is the same but window is up.
rear windows work from all switches but very laboured and slow.
...How do I get my driver side window up ??? have door card off..

HELP :D
 

·
Registered
Joined
·
137 Posts
Discussion Starter #4
fuses ok wiring ok, battery seems plenty juicy.

the drivers and passengers switches both died at the same time tonight and the rear window switches still work - this must be important! ...so it can't be the switches, connections or motors... can it? both wouldn't go at the same time would they?

not sure this is relavant but had engine management light come on 2 days ago -lambda sensor 1 , sure this is a connector problem though...
 

·
Registered
Joined
·
137 Posts
Discussion Starter #6
...not getting anywhere, is there a way of manually closing the window? I can get to the glass but it wont budge...
 
G

·
Guest
Joined
·
0 Posts
Yes... Get some jumper cables, one pair of clips on the battery terminals and the other pair to connect two separate wires to. Remove the main switch housing from the door panel and unclip the multiplug to the faulty switch.
Using stripped ends of your positive and negative wires that are attached to the respective jumper cable clips, touch the multiplug terminals.. If it goes further down or you hear the motor stop, reverse the wires on the terminals and it will go up
Job done;)

Bring back Tapatalk !!!
 

·
Registered
Joined
·
137 Posts
Discussion Starter #8
ok there is good news and bad... the good news is the window is up! yey!

Bad news is central locking doesn't work!>?

I tried the wires straight from the battery to the switch, the window didn't move but...it started smoking and nearly melted one of the wires from the connector block! then I turner the ignition on and tried the switch again and the window went up!? once the window was up the switch stopped working again. its like the switch isn't getting power, all the other switches (rear switches and window lock button) are illuminated, the front window switches are not.

then I try to lock the car and the central locking has stopped working? remote or key = no joy, alarm still activates though...

...oh joy!
 

·
Registered
Joined
·
137 Posts
Discussion Starter #9
... Err, this has all fixed its self!?

Really don't have an answer, don't even know what broke! :D
I'm tempted to blame the connector block gremlin!
 
1 - 9 of 9 Posts
Top