Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter · #1 ·
My Brake Fluid Warning light started going off when driving, so I bought some...

I took the cap off a poured the fluid in, however, the fluid didn't make it to the tank, it just sat on top of another bit of plastic.

What have I done wrong?

P.S I'm aware how stupid this sounds and have my vagina being sent in the post :cheese:
 
G

·
There is a plastic filter inside the cap, it will go through eventually. If it's clean fluid then I would remove it to fill it up.
 

·
Registered
Joined
·
30,291 Posts
Did you take the cap right off, or just lift it slightly?

There is a float attached to the cap that is used to check the level.
You need the cap (with float) lifted clear.
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #4 ·
The black cap on top just came off with nothing attached to it, there is some clear plastic inside the neck thats stopping the fluid from getting into the tank.

The beeping is really ****ing me off, I might just put a hole through the clear plastic bit.
 

·
Registered
Joined
·
30,291 Posts
Before you started pouring fluid in, did you actually check the level?
(by looking at the level through the side of the reservoir...)

If the float isn't attached to the cap, that is probably why it is saying the level is low...!!
(the switch that the float works is in the cap)
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #6 ·
Before you started pouring fluid in, did you actually check the level?
(by looking at the level through the side of the reservoir...)

If the float isn't attached to the cap, that is probably why it is saying the level is low...!!
(the switch that the float works is in the cap)
It's not that low, halfway between min and max...

How do I sort this out then? is it broken?
 

·
Registered
Joined
·
30,291 Posts
It's not that low, halfway between min and max...
At that level, the light would not be on. It should only warn when it gets to "MIN".

How do I sort this out then? is it broken?
It sounds like it has broken. Unless the float will clip back into the cap.

If broken, it just means a replacement cap+float.
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #8 ·
At that level, the light would not be on. It should only warn when it gets to "MIN".


It sounds like it has broken. Unless the float will clip back into the cap.

If broken, it just means a replacement cap+float.
Thanks :)

Is there any danger of anything if I rip the clear plastic out that's blocking me topping up?

I'm getting worried about my whole breaking system, the pedal is feeling spongy and my clutch pedal has varying pressures.
 

·
Registered
Joined
·
30,291 Posts
Without wanting to cause offence....... have someone that knows what they are doing take a look at it.
 

·
Registered
Joined
·
2,541 Posts
If that is the float, try taking it out as it will have to come out sometime. The spongy feel is usually due to air in the system so may require bleeding. The level dropping may be worn pads/discs but as David C said get it checked.
 
1 - 11 of 11 Posts
Top