Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all.

New to the group and need help with my 2005 1.9JTD Alfa GT if you could please.

Today as I started out driving I pressed the windscreen button on my heating / AC panel to clear the screen. The tempature was reading 15°c on the dash and the heating / AC was set to 19°c. After about 5 mins of driving a strong burning electrical smell started to come through the vents closely followed by white smoke coming from the engine bay 😣
Car still drives fine so I'm assuming it's definitely a problem with the heating / ac?

I will probably get some time to investigate it tomorrow but does anyone happen to have any ideas what may of caused this before I start poking around?

Thanks in advance
Gg
 

·
Registered
Joined
·
30,290 Posts
Has your Diesel got the auxiliary heater?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Hi David

Thanks for the reply.

Trying not to sound dumb here but how would I know?

I've only had the car a few weeks and it's my first Alfa
 

·
Administrator
Alfa 159 1.9 JTDm Sportwagon
Joined
·
5,809 Posts
Does the heater fan still work at all speeds?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks for the reply Paul.

I have literally just discovered what the problem is. It turned out to be the air con compressor / pump which leads onto my next question.

Any ideas on how much it's to get replaced or how hard it is to replace yourself?
 

·
Registered
Joined
·
3,563 Posts
It can be changed yourself but the gas should be recovered before changing and would need to be recharged afterwards.
 
1 - 6 of 6 Posts
Top