Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hello alfadrivers ;-)

I have a big big problem with the windows in my alga GT 2005 ...

The windows kind of have their own life .. sometimes they wont wind down at all, sometimes they wind down on their own, and sometimes they go halfway up and then down again and in that situation the only way to wind them up, is to do it in small steps ..

the problem started in the right side window, but has now spread to the other side as well ...

Any god ideas what's wrong ?

REGARDS, JEPPE
 

·
Registered
Joined
·
105 Posts
Have you tried a reset, hold windows down for 10 secs then up for 10 secs, there's a few threads on windows reset you could have a search for.
Cheers
 

·
Registered
Joined
·
137 Posts
Try cleaning up the door wiring connectors, in the hinge gap when the door is open there will be a fat black corrugated tube with all the wiring for the windows, locks, mirrors etc...
un-clip it and clip it in again, this solved my window problem - I was actually trying to get the door speakers to work again when I found this solution...

connectors connectors, every time!
 
G

·
Guest
Joined
·
0 Posts
Could be the switch or on the 147 there is an electronic window control box but not sure if the same is on the GT this could be faulty had this on the 164 as well drove me mad for ages :thumbs:
 

·
Registered
Joined
·
13,685 Posts
Mine did this over the weekend. I had the window wound two thirds down, the A/C is broke in mine. I got out and then back in the car and when I closed the [driver's] door the glass went up hit the top rubber and came down. I could carefully wind it up to the top (if I did it on auto or a long push it went down again) and it would stay up :)lol:) until I closed the door or opened/closed at which point down it went :lol:. A reset did nothing.
At home I loaded the channels and top rubber seals with silicone spray (before I saw this thread) and eventually after several up and downs it all seems good again.
So the lubricant is a good idea. I'm sure it was the safety protection that prevents trapped hands and my guess are the stiffer she gets :p the more resistance and eventual activation of the 'safety feature'.
I lubricated the passenger side and they do both sound and work much better. The glass needed a good clean as plenty of silicone went everywhere.
I also noticed whilst this feature was operating the window drop when opening and closing the door did not work.

Incidently I need a new drivers wiper blade as mine judders, the silicone spray on that has given it (temporary I'm sure) relief :thumbs:
 
1 - 8 of 8 Posts
Top