Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
630 Posts
Discussion Starter #1
Hoping someone can shed some light on this as the internets is dumbfounded. I have two sets of Eibach springs for the GTA (111000101HA) However next to the Eibach logo one has Y/T and the other has Y/Y-1

Is this significant or just some internal code for manufacturing date or something???
 

·
Registered
Joined
·
2,037 Posts
Hoping someone can shed some light on this as the internets is dumbfounded. I have two sets of Eibach springs for the GTA (111000101HA) However next to the Eibach logo one has Y/T and the other has Y/Y-1

Is this significant or just some internal code for manufacturing date or something???
Why not email eibach?

Sent from my SM-G950F using Tapatalk
 

·
Registered
Joined
·
630 Posts
Discussion Starter #3
Looks like I'll have to, no one seems to know. Was hoping for a quick response as I'm in the middle of a job on the rear of the car and wondering if I should swap the rear springs as the car is sitting very high at the back even though these are lowering springs. Front is good but rear is same as standard
 

·
Registered
Joined
·
4,208 Posts
are the springs off and the same height .. i had to drop the rear of mine 40mm or more to get it looking level and correct arch gaps..
 

·
Registered
Joined
·
630 Posts
Discussion Starter #5
Hey mate, they are the Eibach pro lowering springs, the front has gone down perfectly but the rear is the same as OEM, the springs are all from the same set
 

·
Registered
Joined
·
4,208 Posts
wonder if you got sw springs seems odd it hasnt lowered the rear not sure i can help much.. i always measure units off the car as it seems common to get the wrong springs some times
 
1 - 6 of 6 Posts
Top